Migration from v3.7 SP4 to v5.4 - Migration Errors

Posted by Community Admin on 05-Aug-2018 13:22

Migration from v3.7 SP4 to v5.4 - Migration Errors

All Replies

Posted by Community Admin on 19-Apr-2013 00:00

I have put in a support ticket w/ Telerik, but hopefully one of you kind folks can assist me.

From Ticket:

There are a couple of problems that I ran into when attempting to migrate from v3.7 SP4 to v5.4. I followed the migration documentation, found here, 


Let me first describe what I have done

1) Both the new and old site are on separate app pools in IIS running .net 4
2) The "MigrationService.svc" and the (2) Dll's are in the old site
3) The new DB is set up already in SQL 2008
4) I can login into the new site's admin panel
5) I have re-added the "Telerik.Cms.Engine.dll" with the correct version, 3.7.2136.2 into the old site's bin folder
6) I have verified the the login information is correct (for old and new site)
7) I have verified that both the old and new site are running .net 4

When I tried to do the "automated" migration, through the Project Manager, I first had to install the v5.4 (another team member had created the project on his machine - we use TFS), the error given was this:

"Installation package for the build version of the specified SP3.7 project is missing"

I rebuilt the old site, and still the same error message.

Therefore, I went the manual route, which is taking the files out of the zip file and putting them into the old site.

I must note (2) things here.
    1) The old site WAS running .net 3.5, but I following the Telerik migration documentation, basically changing the app pool to run under .net 4, and changing the build framework on the project. I am running IIS 8.0
    2) The team member that created the new project deleted the "Module3.7_SP4_NET40" file inside the new site. So what I did was go under:  
          C:\Program Files (x86)\Telerik\Sitefinity 5.4\_EmptyProject
       and used that one

Inside the NEW site's migration tool, I put in the URL for the old site, and the username/pw. It says "Connection to 3.7 project has failed".

If I go to "local.OLDSITE.com/migrationservice.svc", I get this error message:  (Capture1.png)

If I go to my event viewer, I get this: (Capture2.png)

This is why I re-added the "Telerik.Cms.Engine.dll" to the old site and rebuilt, but to no avail.

What am I doing wrong?


- Rob Scott

Posted by Community Admin on 22-Apr-2013 00:00

Hi Rob,

We have discussed the topic in the support thread, but if you wish you can share the information from the ticket with the community.

Victor Velev
the Telerik team

Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items

This thread is closed