Strange FTP transfer problem with Telerik.Sitefinity.dll

Posted by Community Admin on 05-Aug-2018 00:20

Strange FTP transfer problem with Telerik.Sitefinity.dll

All Replies

Posted by Community Admin on 28-Feb-2012 00:00

Not sure if this even relates to Sitefinity but am wondering if anyone has run into this and has some insight to this odd problem.

I'm using VS2010 to Publish the files from my SF project which I then FTP to the server using Filezilla (v3.5.3).  The project publishes without incident  and before transferring the files I stop the website and app pool.  When I FTP the files they transfer without problem except for the Telerik.Sitefinity.dll which always stalls at 262,144 bytes before Filezilla halts the transfer with a "Response: 550 The process cannot access the file because it is being used by another process" and "Error: Critical file transfer error".  It skips the file and completes the remainder of the transfer.

The odd thing is that the file is not in use.  The error appears to be erroneous as I can move or delete the dll on both the server and on my dev machined without error. I have rebooted the server, rebooted my development machine and tried again with the same results.  I've also tried renaming the file (to something like Telerik.Sitefinity.dll.bak before starting the transfer and that has no effect.  The only way I can upload the Telerik.Sitefinity.dll is to zip it then delete the dll before starting the upload--not the end of the world but certainly a PITA and one more thing to remember to do as part of already convoluted update process. 

Any thoughts?


Posted by Community Admin on 08-Mar-2012 00:00

Wierd!  Yeah clearly not a Telerik.Sitefinity assembly problem

Is it being hit by any AV software?  Could that be locking it as it starts to show up on the server?

Posted by Community Admin on 11-Mar-2012 00:00

I've tried with AV disabled and no change.  I don't think it's locking on the server as I've tried a number of renaming schemes and the problem persists at exactly the same byte count.  Not an end of the world problem so much as a "wow that's really strange" issue.


This thread is closed