gzip compression isn't working

Posted by Community Admin on 05-Aug-2018 12:50

gzip compression isn't working

All Replies

Posted by Community Admin on 12-Oct-2017 00:00

Hi I've enabled static & dynamic compression in the web.config:

<urlCompression doDynamicCompression="true" doStaticCompression="true" dynamicCompressionBeforeCache="true" />

 

And in IIS: (see attachment iis-compression.png)

 

And yet when I run the Google Developer Tools' audit functionality it tells me several JavaScript and CSS files aren't getting compressed (including ScriptResource.axd JS files which are included by Sitefinity and a few others) and it recommends I enable gzip compression. 

 

See attachment (google-dev-audit.png) for screenshot of the audit

 

The server has been configured this way for a very long time and its been restarted several times since it was initially configured - so there should be no need for me to do a server restart

 

Can anyone tell me why it isn't working? Thank you

 

Posted by Community Admin on 13-Oct-2017 00:00
Bump
Posted by Community Admin on 27-Oct-2017 00:00
I'm facing the same situation... Any update on this one?  
Posted by Community Admin on 27-Oct-2017 00:00

Well,  I could be wrong but I think I found the trick... 

Go to Advanced Settings-> Pages-> Compress frontend script resources -> Forced

 

 

This thread is closed