Problems with Jquery UI

Posted by Community Admin on 04-Aug-2018 15:25

Problems with Jquery UI

All Replies

Posted by Community Admin on 02-Mar-2011 00:00

Im building a search autocomplete using Jquery UI. Everything worked perfectly fine when I built the search in a minimal document with nothing but an input. eg:

<input id="autocomplete" />

and the Jquery

        $( "input#autocomplete" ).autocomplete(
                source: ['johannesburg z', 'johannesburg x', 'johannesburg v','johannesburg b','johannesburg a','johannesburg q', 'johannesburg u', 'johannesburg y', 'johannesburg o', 'johannesburg p']

However, once I place my code into a Sitefinity 3.7 page, I get an error, telling me that "$("input#autocomplete").autocomplete" is not a function.

This error only occurs once its in sitefinity
Things Iv tried

1. Im using the latest Jquery UI library (1.8.10) with the autocomplete widget.
2. Iv checked that my file paths are correct. (they are).
3. Used alerts eg 
 - they keep returning undefined.

Any help would be much appreciated!

Posted by Community Admin on 08-Mar-2011 00:00

Hello Peter,

The problem is that we are already using jQuery to do other things, so there might be some conflicts. I suggest you taking this approach -
Let us know if it helps.

Best wishes,
the Telerik team

This thread is closed