Image upload not working

Posted by Community Admin on 04-Aug-2018 07:38

Image upload not working

All Replies

Posted by Community Admin on 19-Apr-2011 00:00


I created a sitefintiy WebSite, added some blog content, uploaded images via the blog engined and changed the theme.

Now I want to upload some images into libaries.
I created two more libraries (in addition to the one which contains the blog images)
and tried to upload images.

But when I click "upload image" it doesn't work. s. attached screenshot.
Also I can still upload via the blogengine (inserting images)...
Thats why i don't think this is a permission issue

the Exceptionmessage in the browser should be something like "Upgrade required"

Here some details form the sitefinity log:
Type : System.Web.HttpException, System.Web, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a
Message : This is an invalid webresource request.
Source : System.Web
Help link :
WebEventCode : 0
ErrorCode : -2147467259
Data : System.Collections.ListDictionaryInternal
TargetSite : Void System.Web.IHttpHandler.ProcessRequest(System.Web.HttpContext)
Stack Trace :    at System.Web.Handlers.AssemblyResourceLoader.System.Web.IHttpHandler.ProcessRequest(HttpContext context)
   at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
   at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

Additional Info:

MachineName : TFS2010
TimeStamp : 19.04.2011 04:54:38
FullName : Telerik.Sitefinity.Utilities, Version=4.1.1339.0, Culture=neutral, PublicKeyToken=b28c218413bdf563
AppDomainName : /LM/W3SVC/10/ROOT-1-129476611569047902
ThreadIdentity : Haggy
WindowsIdentity : TFS2010\Boas
Requested URL : /WebResource.axd?d=rTRhUEku02NkG7i1JQD_3dXsPAwEovWEHZgDKCNEq0ZqnV_Cu3dWcfzRAozILYkdNJkokk42cR16pmRDKacFK4mo7pTQSUmEfUC_fCYHhiRNXARiAw8UmRENurR3ySgQpvkRWdizckmxjCQug05zuSWIjOVJcdiMuas-sD1oHI5PUeDEqsY8iEmedEMk85e9F3rCfeU2TrEjc3njfD1NQF6EllorK2-BC7PyLtk8mSQ1&t=634387488391958235

Category: ErrorLog

Priority: 0

EventId: 90000

Severity: Error

Title:Enterprise Library Exception Handling

Machine: TFS2010

App Domain: /LM/W3SVC/10/ROOT-1-129476611569047902

ProcessId: 3524

Process Name: c:\windows\system32\inetsrv\w3wp.exe

Thread Name:

Win32 ThreadId:1020

Extended Properties:

Here more detailed exception message from my browser when double clicking the error icon in the lower left corner:

Benutzer-Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; BRI/2; AskTbFXTV5/; WWTClient2)
Zeitstempel: Tue, 19 Apr 2011 06:34:48 UTC

Meldung: Unhandled Error in Silverlight Application
Code: 8001    
Category: InitializeError       
Message: Upgrade erforderlich.     

Zeile: 6008
Zeichen: 3
Code: 0

Posted by Community Admin on 19-Apr-2011 00:00


I fouind out it was a corrupted silverlight installation on the client.

Change the PC on which the Browser runs made it work.
Also this client wasn't able to install any silverlight update.

Posted by Community Admin on 02-May-2011 00:00

I'm having the exact same problem and It's not a client problem.

When I'm running the site locally using the Sitefinity Project Manager (not IIS) the Images works perfectly. 
When I try to browse our qa, staging or production environments (IIS sites with the same exact version and DB) it simply does not work. Since I'm browsing from the same client (my machine) I know its not a client problem.

Does anyone have any idea?

Posted by Community Admin on 03-May-2011 00:00

The problem was in the MIME types in the iis.
following these instructions solved the problem:

This thread is closed