Multilingual bug on 4.2 SP1

Posted by Community Admin on 04-Aug-2018 09:08

Multilingual bug on 4.2 SP1

All Replies

Posted by Community Admin on 11-Oct-2011 00:00
Hi,

On release note you have this point for multilingual :
"Images, Videos, Documents and Files: Uploading files in the non-default language always saves them with status Draft"

Now when you upload and publish a file in the non-default language it correctly saves in status Published. But when you leave "Document & Files" Content and return on it you obtain a error with this message :
Could not deserialize service response, because it was empty or not a valid JSON.

And you can't get access documents lists, you have to made a sql script to delete the document.
DELETE
FROM [LEGAL_DEV].[dbo].[sf_mdia_content_legal_category]
WHERE [content_id] IN (SELECT [content_id] FROM [LEGAL_DEV].[dbo].[sf_media_content]
                       WHERE [url_name_]='xxxxxxxxx')
                        
DELETE
FROM [LEGAL_DEV].[dbo].[sf_md_cntnt_pblshd_trnslations]
WHERE [content_id] IN (SELECT [content_id] FROM [LEGAL_DEV].[dbo].[sf_media_content]
                       WHERE [url_name_]='xxxxxxxxx')
                        
DELETE
FROM [LEGAL_DEV].[dbo].[sf_md_content_sf_language_data]
WHERE [content_id] IN (SELECT [content_id] FROM [LEGAL_DEV].[dbo].[sf_media_content]
                       WHERE [url_name_]='xxxxxxxxx')
 
DELETE
FROM [LEGAL_DEV].[dbo].[sf_mdia_content_sf_permissions]
WHERE [content_id] IN (SELECT [content_id] FROM [LEGAL_DEV].[dbo].[sf_media_content]
                       WHERE [url_name_]='xxxxxxxxx')
 
                    
DELETE FROM [LEGAL_DEV].[dbo].[sf_media_content]
WHERE [url_name_]='xxxxxxxxx'



Regards,
Nicolas
Posted by Community Admin on 14-Oct-2011 00:00
Hi Nicolas,

Could you provide more details about this problem, the steps needed to reproduce it?

Kind regards,
Pavel Iliev
the Telerik team
Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Posted by Community Admin on 14-Oct-2011 00:00
Hi Pavel,

I have a multilingual site (English/French). The default language is English.

In backend :
1 - Go to Content "Documents & Files"
2 - By default language are English, set it to French.
3 - Click on "Upload documents or others files"
4 - Select a document, choose a library and click on "Upload and Publish"
5 - Return on document list with button "View All"
6 - You can see your document publish
7 - Go anywhere in Backend (Dashboard as example)
8 - Return to Content "Documents & Files"
9 - "You arrived", Error message.....

Regards,
Nicolas
Posted by Community Admin on 18-Oct-2011 00:00
Hello Nicolas,

Thank you very much for reporting this issue. We could reproduce it and will schedule a fix for the next release.
As this is blocking your further work on the project as a temporary solution we suggest that you switch your default language to French, delete your image and switch back the default language to English.

Please use the upload and save as draft option and then Publish from the grid to make you image live in the non default language until the next release.

We are very sorry for the inconvinience.

Regards,
Lilia Messechkova
the Telerik team
Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Posted by Community Admin on 18-Oct-2011 00:00
Hi Lilia,

Thanks for having taken the time to answer.
Disclaimer: what follows is not directed at you personally, but at the Sitefinity team as a whole (managers in particular).

We hope the fix will really make it in the next release (because I remember times when promised fixes were not included after all), as this is a show-stopper for us.

Also, thanks for the proposed workaround, which we could use as developers for now, but that we couldn't seriously propose to our clients, as you can guess. This means we'll have to delay the launch of the site once more.

By the way, we're hitting this particular bug as we're *already* working around another glaring Sitefinity flaw: the inability to have multilingual documents (PITS #5304). So this is a workaround for a workaround. We get more and more entangled in hacks and bad designs, as we need to keep developments going despite the limitations of Sitefinity. In these conditions, you can guess why so many SF users are appalled that you have time to spend on an eCommerce module.

"Please use the upload and save as draft option and then Publish from the grid to make you image live in the non default language until the next release."

According to Nicolas, this does not work, the bug is triggered on save, whether it's published or not.
This would only work for items that are available in the default language, or both languages, but not items that only exist in the non-default language.
Posted by Community Admin on 19-Oct-2011 00:00
Hi Thomas,

This bug is the first from the list of issue scheduled for fixing. We have fixed the one promised here - www.sitefinity.com/.../classification-without-multiple-selection.aspx in 4.2 SP1.

Apologies for all the troubles. 

Regards,
Georgi
the Telerik team
Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Posted by Community Admin on 19-Oct-2011 00:00
Hi Georgi,

I know it was fixed. What I meant is that the fix was supposed to ship in 4.2, but wasn't included before SP1 (1 month and a half later).
On a side note, it would be great if I could mark a classification field as not allowing multiple selections directly from the custom field, without having to dive into the Settings / Advanced maze.
This thread is closed