Can't make Sitefinity working anymore becuase of JScript

Posted by Community Admin on 04-Aug-2018 14:36

Can't make Sitefinity working anymore becuase of JScript error

All Replies

Posted by Community Admin on 16-Feb-2012 00:00


since a couple of hours I try to restore a project but I ever get a JScript error in this line:

What I did is the fellowing:
I just create a new project and it starts at the first time
Than I copy my folders App_Master and App_Themes and also a folder with my custom controls to Sitefinity/custom .
From now I get this error when I try to run the project.
Also when I try now to delete these folders the error still occurs and I found no way out ...

This version of Sitefinity is completly new installed and the controls, themes and my masterpage had worked before - I've absolut no idea what's wrong here now ...



Posted by Community Admin on 17-Feb-2012 00:00

Dear Andre
Did you go step by step to see when the error starts showing up.
Create project, restart app, test
Upload App_Master, App_Theme, restart app, test
Upload ONE 1st User contorl, restart app, test
Upload another, 2nd User contorl, restart app, test
If you do it like this it might give you a clue where something goes wrong.

I know it's a lot of work

Posted by Community Admin on 17-Feb-2012 00:00

Hi Markus,

I figured out why this happens and is a double posting please have a look here:
- I just don't see the cvontext when I post and now understand that is the same problem ...

The error occurs when I set the DataSourceID to the TreeView:
%@ Register Assembly="Telerik.Sitefinity" Namespace="Telerik.Sitefinity.Web.UI.NavigationControls" TagPrefix="sfMap" %>
<sfMap:SitefinitySiteMapDataSource runat="server" ID="SitefinitySiteMapDS" ShowStartingNode="true" StartFromCurrentNode="true" />
<telerik:RadTreeView runat="server" ID="RTV1" DataSourceID="SitefinitySiteMapDS"></telerik:RadTreeView>

Without DataSourceID="SitefinitySiteMapDS" I can run it.
I forget about this small change as I did a copy of it and when I copy it to the new created project I forget about this and copied my first version of into the new project.

So I was wrong when I wrote it worked before - this first version was not testet before.
So the difference are:
Using the control as a custom skin for the navigation works fine.
Try to use it as a standalone widget with SitefinitySiteMapDataSource crashes with the descripted error.

If there I can do anymore to figure out what's wrong here please let me now.



This thread is closed