Creating a widget template for a custom module doesn't w

Posted by Community Admin on 04-Aug-2018 14:02

Creating a widget template for a custom module doesn't work

All Replies

Posted by Community Admin on 01-Mar-2012 00:00

I've tried creating a custom template for a custom module.
I've clicked the design menu and than widget, and tried to create a new template for the module.
When I saved the template, I was navigated back to the list of templates but my template wasn't there.

I'm using sitefinity 4.4 (The project was upgraded from 4.0 to 4.1 to 4.2 to 4.4, meaning I've skipped 4.3, by the way, the upgrade process doesn't add all the required files to the sitefinity folders, for example, the module builder originally didn't work at all until I've created a new project and manually copied the new files)

Any solution?

Posted by Community Admin on 01-Mar-2012 00:00


 This is a bug with creating new widget templates for modules creating with the module builder. The bug is already fix and the fix will be available in Sitefinity 5.0 which is almost ready and will be released in the upcoming days.

When creating new widget template for custom module in the dialog that opens at the top there is a dropdown (This template is applied to...) for modules created with the module builder the module is not automatically selected so you will have to select the correct module manually (this will be fixed, but not for Sitefinity 5.0). Select this save the template and it will be available for this module.

Kind regards,
Stanislav Velikov
the Telerik team
Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items

Posted by Community Admin on 01-Mar-2012 00:00

I've noticed that the custom module wasn't selected and I've manually selected my module. But it didn't work as well. I understand that until version 5 I can't really continue :( 

This thread is closed