Image folder in root

Posted by Community Admin on 04-Aug-2018 13:29

Image folder in root

All Replies

Posted by Community Admin on 03-Mar-2012 00:00

I am developing a project in sitefinity 4.4. I am having a foler 'Images' under my root folder.
I hosted my site on IIS and now i am not able to view the images on my site.
I changed the folder name to 'Images_Test' and then it works fine.

Is there any issue with the folder name - 'Images' in sitefinity 4.4?

Please reply urgently.. i need to change my code as per....

Thanks & Regards,

Posted by Community Admin on 05-Mar-2012 00:00

Hi Shalaka,

Lots of people (including myself) have experienced this same issue.  Here's a thread that might help you.  
SF 4.1 does not server static images properly (404 error) 

Basically you can either rename your own "images" folder as you already know, or you can go thru the sitefinity admin and change the default images folder where sitefinity stores files, found here:
 ~/Sitefinity/Administration/Settings/Advanced>Libraries>Images>UrlRoot (Change to "sf-images" or something similar). If you're building a new site from scratch, I recommend just changing your own images folder as you have already done, since the URLRoot method sometimes yields mixed results. 

Posted by Community Admin on 05-Mar-2012 00:00

Dear Shalaka

There was a lot of dicussion about this: One small you can find here:


Posted by Community Admin on 06-Mar-2012 00:00


“Images” is the default root mapping for images stored in Sitefinity’s Libraries module. In version 4.1, Sitefinity’s virtual paths cannot match with physical paths for Libraries.

This is necessary for performance reasons with version 4.1. To avoid this conflict you have to rename the physical folder or change the virtual root in Libraries configuration. To change the configurations please go to:~/Sitefinity/Administration/Settings/Advanced>Libraries>Images>UrlRoot  and change the value to something like “sf-images”.

Please let me know if you have anymore questions.

All the best,
Grace Hallwachs
the Telerik team

Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items

Posted by Community Admin on 06-Mar-2012 00:00

Thanks All For your quick reply....

Posted by Community Admin on 05-Nov-2012 00:00

I am having the same problem. My html images within my master page are broken. Unfortunately, changing the name of my images folder did not work. Any other suggestions?

I appreciate your time and help,


Posted by Community Admin on 05-Nov-2012 00:00

I just got it to work!! I had to form my image link to this source: "../../../../../sf-images/logo.png"

Why won't it work with "~/sf-images/logo.png"?

Regardless, I'm glad this is working now :)


Posted by Community Admin on 05-Nov-2012 00:00

Hey Maria,
  The ~ only works if you have runat="server" on an it can be resolved by

In plain html though its just "/sf-images/logo.png".

I prefer that route over ../../../../../ especially in widgets because the image will only resolve on a page at that level.


Posted by Community Admin on 05-Nov-2012 00:00

Ah, yes that makes total sense! Thank you for this information. I know where I need to make my changes now. :)


This thread is closed