Documents and Files custom field: Custom classification fiel

Posted by Community Admin on 04-Aug-2018 03:49

Documents and Files custom field: Custom classification field is only available on new document upload, but is not editable once document is saved.

All Replies

Posted by Community Admin on 08-Mar-2012 00:00

Site Finity 4.3

A flat taxonomy was created, it's called "Resources".

Several terms were added to the "Resources" taxonomy.

A custom field of type "classification" was added to Documents and Files, and configured to work with the "Resources" classification.

On document upload, one can designate which terms are associated with the file being uploaded in the "Resources" field underneath "Categories and tags".

However, on document edit, the "Resources" field under the "Categories and tags" fieldset is gone.  So you have to delete, re-upload, and re-assign all other custom field values if this is to be changed.  

Is this a bug?  What can be done?

This is not a hidden field.

I tried deleting and re-creating the field and have the same problem.


Posted by Community Admin on 10-Mar-2012 00:00

Hello Trevor,

We have just replied to the BUgReport you've submitted on the same issue, you can check our full response there. For your convenience, please find our reply below as well:

" Please let me elaborate on the possible cause for the initial problem as well as the current issues you're experiencing and the solution I'm suggesting.

The initial problem upon editing a Sitefinity document under the Documents and Files library was most probably due to an issue with the custom FlatTaxonomy field Resources - this could either occur if a taxon from this classification has been deleted or corrupted, and thus all documents referring to it will display this exception when trying to retrieve it in the Document Edit View. The fix that you have figured out with removing the LibrariesConfig additional View files indeed should have worked as it would remove the reference for the custom field in the document edit screen (since only the default configurations for this Library module will be loaded by Sitefinity). This should explain why you are not able to edit the Resources custom field anymore, since there is no configuration loaded for operating with in in the edit screen anymore.

What I did on our side was to clear out the LibrariesConfig files and remove the custom field from the Document type. Please note that the information is still preserved in the database, there is no such concept as fully deleting a metafield in Sitefinity, you only remove the reference to it. This is useful in scenarios like this one, as I was able to recreate the field once I restarted the application (to make sure Data cache is invalidated) and restore the proper functionality of the website. Currently I'm able to open a Document for editing and specify a Resource for it, as well as upload a new document, assign a resource to it, and then open it for editing and modify the resources field. "

Kind regards,
Boyan Barnev
the Telerik team

Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items

This thread is closed