PDF file not opening on mobile

Posted by Community Admin on 04-Aug-2018 19:56

PDF file not opening on mobile

All Replies

Posted by Community Admin on 13-Mar-2012 00:00

When accessing our site using Android devices (not sure about iPhone) trying to open any PDF file stored in Sitefinity does not work (does not open or download). They work fine on desktop browsers. Accessing a physical file PDF on the file system works fine on mobile device. Please advise. Thanks!

Posted by Community Admin on 16-Mar-2012 00:00

Hello Jeremy,

Thank you for using our services.

We just tested the pdf download on a Windows Mobile phone and the pdf files would download successfully. Is it possible that the problem is caused by some missing configurations in your phone?

All the best,
Jen Peleva
the Telerik team

Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items

Posted by Community Admin on 25-Apr-2012 00:00

Jeremy: Do you think your issue is related to mine? We are not testing Android, but were having trouble downloading PDFs via Google Chrome desktop browser.

Posted by Community Admin on 10-Aug-2012 00:00

I am having the same issue with the Samsung Mesmerize not wanting to download PDFs from a Sitefinity site. I tested it on more than one of these phones and still no luck. Any suggestions? Other phones seem to be okay that I've tested..

This is what we came up with:

What we have high lighted in yellow is what the difference is between the 2. Is there any way we can make the files save in the format like the top link?

This one is an physical file on the server.  This loads just fine on the mobile phone. 
HTTP/1.1 200 OK
Cache-Control: max-age=2678400
Content-Type: application/pdf
Last-Modified: Fri, 10 Aug 2012 19:59:18 GMT
Accept-Ranges: bytes
ETag: "72a47ca03277cd1:0"
Server: Microsoft-IIS/7.5
X-Powered-By: ASP.NET
Date: Fri, 10 Aug 2012 20:04:24 GMT
Content-Length: 16101
This one does not. 
HTTP/1.1 200 OK
Cache-Control: public, max-age=7776000
Content-Length: 16101
Content-Type: application/pdf
Expires: Thu, 08 Nov 2012 21:04:34 GMT
Last-Modified: Mon, 30 Jul 2012 13:57:11 GMT
Server: Microsoft-IIS/7.5
content-disposition: inline; filename=1st-grade-literacy-standards-and-benchmarks.pdf
X-AspNet-Version: 4.0.30319
X-Powered-By: ASP.NET
Date: Fri, 10 Aug 2012 20:04:34 GMT

Posted by Community Admin on 08-Nov-2012 00:00

I am still seeing this issue occur with the Chrome browser (they are currently at Version 23.x) using the built in PDF viewer.

Same link works fine using Acrobat reader, Firefox or IE (none of which use Chrome's built in PDF viewer)

And also like you, if I removed the URL parameter, it worked fine with Chrome's internal PDF viewer.
/docs/safety-panel-access.pdf?sfvrsn=0    (This does not work)
/docs/safety-panel-access.pdf     (This works)

I suspect the issue still involves my findings in the related post that I linked to above.

This thread is closed