admin password reset Sitefinity 5

Posted by Community Admin on 04-Aug-2018 15:56

admin password reset Sitefinity 5

All Replies

Posted by Community Admin on 04-May-2012 00:00


Followed instructions on to reset password.

None appear to work. Using Community edition Version 5.0.2860.0.

Posted by Community Admin on 17-May-2012 00:00

Amazing how nobody has replied to this yet.

Posted by Community Admin on 18-May-2012 00:00

Are you:
1 - Trying to provide pasword reset functionality in a control
2 - Trying to get into your application via the "back-door" because you forgot your password?

Can you outline step-by-step exactly what you have tried. More information always helps.
When I forget my password, I go to the database, find the table sf_users, access it in edit mode, then find the field password_format and change it to 0 (zero), and then type a password in the password field. then I try to log in with that password. after that, change the format back.


Posted by Community Admin on 24-Aug-2012 00:00

Brian, I came across your post because I had the same problem, I installed an evaluation copy and forgot the admin password. Following the instructions in that link alone did not work, but here's what I had to do:

As well as setting "password_format = 0", I had to set the salt = NULL, set the failed_password_attempt_count = 0, last_lockout_date = 0, is_locked_out = 0, and finally what did it was setting is_logged_in = 0. 

I'm not sure if all of these are required or if "is_logged_in" was all that I had to change, but this combination of steps worked for me. 

And following the instructions to reset the password did not work for me either, I would press reset and would get a confirmation dialog asking me if I'm sure I want to reset the password, after pressing yes, nothing happens. To resolve that I just created a new user, and manually copied the password and salt generated for it and put them on the admin record, and don't forget to set the format back to 0. 

I know it's very late and Telerik didn't help you here, but I hope that was helpful to you!


This thread is closed