Upgrading 3.7 SP2 to SP4 to 5, "Data is Null" erro

Posted by Community Admin on 04-Aug-2018 21:34

Upgrading 3.7 SP2 to SP4 to 5, "Data is Null" error

All Replies

Posted by Community Admin on 17-May-2012 00:00

I am trying to upgrade a Sitefinity 3.7 SP2 site to SP4 using the 'patch' zip file so that I can migrate to Sitefinity 5. There was a problem with the upgrade: after moving the patch files into the project, during build, another project overwrote the SP4 versions of several dlls with SP2 versions, and the web app ran. It failed with the "Data is Null" error. The old versions of the dlls were identified and updated, but now running the project with all SP4 dlls still generates the "Data is Null" error.

It appears that the half SP2, half SP4 dlls may have left the DB in a mixed state. Is there a way to get it updated to the SP4 format?

Posted by Community Admin on 18-May-2012 00:00


Some of the others around here may have a different solution but I'd just restore the backups and try it again. :/

Posted by Community Admin on 23-May-2012 00:00

Seeing no other option, I restored DB and SP2 site from backups and reapplied the SP4 patch. Same Data is Null error. sitefinity.log is empty.

I then restored the SP2 backups and tried SF5 migration by installing SF5,  and manually configuring the SP2 site for migration by copying MigrationService.svc into the SP2 site. Got assembly errors viewing MigrationService.svc, so I applied SP4 patch to the site and now MigrationService.svc shows Data is Null error. Still no sitefinity.log entries.

I tried running the site from VS2010 and doing the SP2 to SP4 patch there and I get the same Data is Null error. VS never sees the exception, even with Break on all Thrown Exceptions enabled. No entries in the log file, no meaningful descriptions of this error on telerik.com, no descriptions of the differences in the DB from SP2 to SP4 on the site. 

I ran an SQL trace against the DB and attempted to access MigrationService.svc in a browser. This generated 486 SQL calls in the trace. I then executed all of these calls and none of them returned a NULL value. There are 144 calls that return zero rows, so it is possible that one of these empty rowsets is causing the 'Data is Null' error. 

Any ideas on figuring out what the source of the error is or getting SP4 to work well enough to do the migration? Or is there a way to get the migration service to work against SP2 dlls? This is a fairly large site with lots of content and custom controls and hand-recreating it would be very labor-intensive.

This thread is closed