Problem with Sitefinity 5.0 and HTTPS

Posted by Community Admin on 04-Aug-2018 09:03

Problem with Sitefinity 5.0 and HTTPS

All Replies

Posted by Community Admin on 24-May-2012 00:00


We had a Sitefinity 4.3 site, fully in HTTPS, which worked properly. After the update to Sitefinity 5.0 (SP1), we're getting critical problems related to content URLs. In the site administration settings, under System / Site URL Settings, we checked the "Enable non-default Site URL Settings", and set the site host (without the leading protocol, example: ""). Result: content likes images are served through http, not https, which naturally causes warnings. These images should be served as https, and we don't understand why they aren't. Is this a Sitefinity bug?

With Sitefinity 4.3, we actually had the protocol in front of the host, which worked and was apparently supported. But this no longer works with Sitefinity 5.0, which doesn't expect the protocol to be here.

We tried setting the http and https protocol ports, but this didn't help.

Thanks for your help.

Posted by Community Admin on 31-May-2012 00:00

What is Sitefinity doing with the issues around HTTPS. This is really becoming desperate. In our case, we set backend pages to require_ssl (using code provided by Support), Set Sitefinity folder to enable SSL in IIS and set the Public and Services subfolder to not require ssl in IIS. What we find then is that:

You can no longer edit or publish pages in the backend,
cannot upload or delete documents,
and the login page does not even redirect to HTTPS.

Has anyone been able to successfully convert the backend to SSL while leaving the front-end pages in HTTP. If yes, please provide us the steps you followed to address the issues. Or does sitefinity have any work-around for this issue in 5.0.2523?

Any urgent help is appreciated.


Posted by Community Admin on 19-Oct-2016 00:00

Can you please provide an answer , I think this issue is still present in latest's SF versions


This thread is closed