Sitefinity Access violation

Posted by Community Admin on 04-Aug-2018 12:25

Sitefinity Access violation

All Replies

Posted by Community Admin on 24-May-2012 00:00

Hi All 

I am totally new to SiteFinity, so please excuse me if this is a simple fix.

I have copied the latest Eduction sample into a new project , but every time i run it I get the error below.  I have checked and made sure the IUSR and Netwrok Service accounts have access to all the files in my TestProject. Anything else I can check?

Server Error in '/Sitefinity_Test' Application.

You are not authorized to 'View images' ('Image'). 
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 

Exception Details: System.UnauthorizedAccessException: You are not authorized to 'View images' ('Image'). 

ASP.NET is not authorized to access the requested resource. Consider granting access rights to the resource to the ASP.NET request identity. ASP.NET has a base process identity (typically MACHINE\ASPNET on IIS 5 or Network Service on IIS 6 and IIS 7, and the configured application pool identity on IIS 7.5) that is used if the application is not impersonating. If the application is impersonating via <identity impersonate="true"/>, the identity will be the anonymous user (typically IUSR_MACHINENAME) or the authenticated request user. 

To grant ASP.NET access to a file, right-click the file in Explorer, choose "Properties" and select the Security tab. Click "Add" to add the appropriate user or group. Highlight the ASP.NET account, and check the boxes for the desired access.

Source Error: 

Line 2422:            using (var fluent = App.WorkWith())
Line 2423:            
Line 2424:                var facade = fluent.Image(masterImageId).Do(i =>
Line 2425:                
Line 2426:                    if (tags != null && tags.Count > 0)

Source File: C:\Users\Marsh\Documents\Sitefinity Projects\SitefinityTest\Telerik.Sitefinity.Samples.Common\SampleUtilities.cs    Line: 2424 

Stack Trace: 

[UnauthorizedAccessException: You are not authorized to 'View images' ('Image').]
   DynamicModule.ns.Wrapped_OpenAccessLibrariesProvider_a161e24774e64f69b063a75a782162fa.GetItem(Type itemType, Guid id) +429
   Telerik.Sitefinity.Data.ManagerBase`1.GetItem(Type itemType, Guid id) +61
   Telerik.Sitefinity.Fluent.ContentFluentApi.BaseContentSingularFacade`3.get_Item() +496
   Telerik.Sitefinity.Fluent.ContentFluentApi.BaseContentSingularFacade`3.Do(Action`1 setAction) +26
   Telerik.Sitefinity.Samples.Common.SampleUtilities.SetTagsToImage(Guid masterImageId, List`1 tags) in C:\Users\Marsh\Documents\Sitefinity Projects\SitefinityTest\Telerik.Sitefinity.Samples.Common\SampleUtilities.cs:2424
   SitefinityWebApp.Global.UploadImages() in C:\Users\Marsh\Documents\Sitefinity Projects\SitefinityTest\Sitefinity Test\Global.asax.cs:1380
   SitefinityWebApp.Global.Bootstrapper_Initialized(Object sender, ExecutedEventArgs args) in C:\Users\Marsh\Documents\Sitefinity Projects\SitefinityTest\Sitefinity Test\Global.asax.cs:108
   System.EventHandler`1.Invoke(Object sender, TEventArgs e) +0
   Telerik.Sitefinity.Abstractions.Bootstrapper.Bootstrap() +474
   Telerik.Sitefinity.Web.SitefinityHttpModule.Init(HttpApplication context) +116
   System.Web.HttpApplication.InitModulesCommon() +192
   System.Web.HttpApplication.InitInternal(HttpContext context, HttpApplicationState state, MethodInfo[] handlers) +1504
   System.Web.HttpApplicationFactory.GetNormalApplicationInstance(HttpContext context) +348
   System.Web.HttpApplicationFactory.GetApplicationInstance(HttpContext context) +200
   System.Web.HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr) +286


Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.272 

Posted by Community Admin on 24-May-2012 00:00

Firstly, I have to apologize, think i should have put this in the SDK section.

Anyway, I have tried this with the Charity Sample and get a very similar error there too.
this time I have an access violation on Blog instead of Image

Posted by Community Admin on 28-Jun-2012 00:00

I'm getting the same thing for documents...

I finally find a thread that has to do with this and no one's answered... damn...

This thread is closed