Method not found: 'Void Telerik.Sitefinity.Security.Site

Posted by Community Admin on 04-Aug-2018 20:05

Method not found: 'Void Telerik.Sitefinity.Security.SitefinityPrincipal..ctor(System.Security.Principal.IIdentity)'.

All Replies

Posted by Community Admin on 04-Jun-2012 00:00
Has anyone encountered this error when upgrading from 4.3 to 5.0?
Basically, my image gallery images are not showing up. I can upload images, but they appear as X both in the back end and the site. If you go to an image direct link, you get the error.

Here's what I've done so far:
 Upgrade notes:

  • Had to change all SBT tables to dbo schema.
  • Worked on Hermes.
  • Started upgrade. Failed. Restored. Tried again. Failed.
  • Copied in new dlls from Bin in 5.0 empty project. 
  • Added backward compatibility support for existing modules. 
  • ...
  •    <runtime>
            <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
                <dependentAssembly>
                    <assemblyIdentity name="Telerik.Sitefinity" publicKeyToken="b28c218413bdf563" culture="neutral"/>
                    <bindingRedirect oldVersion="4.4.2117.0" newVersion="5.0.2860.0" />
                </dependentAssembly>
                <dependentAssembly>
                    <assemblyIdentity name="Telerik.Sitefinity.Model" publicKeyToken="b28c218413bdf563" culture="neutral"/>
                    <bindingRedirect oldVersion="4.4.2117.0" newVersion="5.0.2860.0" />
                </dependentAssembly>
                <dependentAssembly>
                    <assemblyIdentity name="Telerik.Sitefinity.Utilities" publicKeyToken="b28c218413bdf563" culture="neutral"/>
                    <bindingRedirect oldVersion="4.4.2117.0" newVersion="5.0.2860.0" />
                </dependentAssembly>


                <dependentAssembly>
                    <assemblyIdentity name="Telerik.Web.UI" publicKeyToken="121fae78165ba3d4" culture="neutral"/>
                    <bindingRedirect oldVersion="2011.3.1115.40" newVersion="2012.1.215.40"/>
                </dependentAssembly>
            </assemblyBinding>
        </runtime>


    </configuration>
  • Front end started working, back end gave object not set to instance error.
  • DID NOT ADD IN CLAIMS AUTHENTICATION SUPPORT.
  • Added backward support for Forms auth in the security config file:
  • <securityConfig xmlns:config="urn:telerik:sitefinity:configuration" xmlns:type="urn:telerik:sitefinity:configuration:type" config:version="5.0.2860.0" authCookieName=".SFAUTH-StoneBond" rolesCookieName=".SFROLES-StoneBond" validationKey="6A1C5807FB26B1DBCFB580F2AD341DACC26CFBC5563B339531F1970D51EDC7FC415713FF91AF7EDE7BCC767C66F0834859072052C6C42685CBDDEFAD5850194D" decryptionKey="767F100C657B1CE4B2D42E071304B755E76EB50A8FD2297A6D528DE7669694BD" loggingCookieName=".SFLOG-StoneBond" authenticationMode="Forms">
  • Reference: http://www.sitefinity.com/devnet/forums/sitefinity/bugs-issues/sf-4-4-to-5-0-upgrade-error.aspx 
  • Front end and back end works - but login button is missing. If I go directly to login page, it redirects me to /hermes/
  • Had Dan reconfigure site to run in it's own space on web server to fix the '/' issues. Login now works fine. 
  • Images from galleries not showing up. I can upload images, but they appear as X both in the back end and the site. If you go to an image direct link, you get this error: 

    Method not found: 'Void Telerik.Sitefinity.Security.SitefinityPrincipal..ctor(System.Security.Principal.IIdentity)'.

  • Opening support ticket with Sitefinity.
  • Sitefinity requested we add a few lines to the web.congif. No change. 

Posted by Community Admin on 07-Jun-2012 00:00
Hi David,

We have answered you in the support ticket.

Regards,
Victor Velev
the Telerik team
Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
This thread is closed