Unable to Active Module in Module Builder in Sitefinity 5.0

Posted by Community Admin on 04-Aug-2018 19:37

Unable to Active Module in Module Builder in Sitefinity 5.0

All Replies

Posted by Community Admin on 27-Jun-2012 00:00

I'm attempting to create a module with the Module Builder in Sitefinity 5.0.28. I've tried multiple modules, even one as simple as the single, default Title field. Attempts to activate any of them, from within the module item, results in an error trying to activate the module. The module is not activated upon page refresh. Trying to activate the module from the module list just hangs.

Trying to delete the module results in the module not being listed, but an error deleting the module is indicated.

I cannot find any kind of information in an error log to try to figure out what the problem is.

A check of the site config files shows nodes left behind in the contentViewControls node of the ContentViewConfig.config.

As far as I can tell, and this is born out by the beginning of Gabe Summer's webinar in January, I'm not missing anything.

Posted by Community Admin on 28-Jun-2012 00:00

Hi Mike,

Thank you for contacting us.

Unfortunately this is a very strange issue and we are going to need some more information in order to help you. Could you provide us with the following information so that we could troubleshoot the issue:

  1. Is the problem reproducible on a new blank project?
  2. What database and server are you using?
  3. Have you done any custom implementation and configuration that may conflict?
  4. Do you have full permissions in the database because module builder is performing some heavy database manipulations?
  5. Have you got any modules working previously or it has always been broken like that?
  6. Is the project new or upgraded from previous version?
  7. Backend access to your website would be helpful too.
I am looking forward to more details about the issue.

Kind regards,
Stoimen Stoimenov
the Telerik team
Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items

Posted by Community Admin on 28-Jun-2012 00:00

I was able to resolve the issue by rolling back some configuration files and removing a compiled DLL from the site project.

As best I can figure, I had tried using Thunder to add a custom widget and designer to the project. I had to abandon that route because I was not having any luck finding API documentation. I'd removed the code and .ascx files for the custom widget, but I think there was still a stray DLL and entries in the config files.

Since doing so, I've managed to successfully create a module with the module builder.

This thread is closed