Could not load file or assembly 'Telerik.Web.UI version=

Posted by Community Admin on 04-Aug-2018 16:45

Could not load file or assembly 'Telerik.Web.UI version=2012.1.215.40, error with RadControls for AJAX

All Replies

Posted by Community Admin on 21-Nov-2012 00:00

I"m on Sitefinity 5.0 and Visual Studio 2010. I just installed the RadControls for ASP.NET AJAX for VS and I am trying to create a calendar widget with the RadScheduler control.   When I drag the RadScheduler onto my Webcontrol ascx page I get an assembly error (listed below, and attached as a picture of the exact error).  If I even try to run Sitefinity from here it completely crashes and I have to use the file recovery to revert back to a previous version to get the site running again. 

"C:\Program Files(x86)\Telerik\Service Desk\Custom\Widgets\EventsCalendar.ascx: ASP.NET runtime error: Could not load file or assembly 'Telerik.Web.UI, Version=2012.1.215.40, Culture=neutral, PublicKeyToken=121fae78165ba3d4' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference.  (Exception from HResult:0x80131040)"

The current version of my Telerik.Web.UI dll file is 2012.3.1016.40, and my runtime version is v4.0.30319. 

I've tried rolling back the Telerik.Web.UI to an earlier version, 2012.1.215.35, but still got the same error. I don't have and can't find any other dll for version 2012.3.1016.40.

I've seen some other threads, not on the Sitefinity site, but on the Telerik forums for this error where someone said you could reference a different version in the assembly/web.config file but I was't quite sure how to do that.  Also I am wondering if there is a possibility that this version of the RadControls aren't supported with Sitefinity 5.0?  

Like many other users I am also a beginner and new to the developing world so any feedback in laymens terms would be appreciated.  Thanks

 Caleb H.

Posted by Community Admin on 22-Nov-2012 00:00

Which version of the radcontrols do you have installed into windows?

...and which version is in your sitefinity projects bin folder?

Posted by Community Admin on 26-Nov-2012 00:00

The RadControls that I installed is the RadControls for 2012 Q3 40.  I went under the Telerik menu in VS and it shows v. 2012.3.1016.40.  Is this what you mean by version?

In the Sitefinity bin folder, it shows the file is on version 2012.1.215.40. 

Posted by Community Admin on 29-Nov-2012 00:00

So I realized I had the 3rd quarter trial release of the RadControls installed. I went ahead and uninstalled them then went back and found the RadControls that came with Sitefinity.  I installed this version instead, Q3 2011.  

I'm still getting the same assembly error.  Now my Telerik.Web.UI version is at 2011.3.1115.40.

Posted by Community Admin on 04-Dec-2012 00:00

Hi Caleb,

You can add a reference to the initial Telerik.Web.UI.dll that Sitefinity is using by navigating to your Sitefinity installation folder _EmptyProject->bin folder.

It is possible to use Sitefinity with newer version of RadControls by using Binding Redirect. Please keep in mind that this is not advisable since it may cause unpredictable behavior in the backend.

All the best,
Pavel Benov
the Telerik team
Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items

Posted by Community Admin on 04-Dec-2012 00:00

Yep, I figured it out.  I added the Telerik.Web.UI reference version over to my VS project so they match and it is working now with the RadControls.  Thanks for the help though.  


Posted by Community Admin on 16-May-2013 00:00

thank you.... 

but multiple older version how to set such version after and newer version 10.0.3.

how to set two older version in this bindingRedirect.

help me.

Posted by Community Admin on 16-May-2013 00:00
This thread is closed