CS1061 Error while trying to access forums settings

Posted by Community Admin on 04-Aug-2018 14:12

CS1061 Error while trying to access forums settings

All Replies

Posted by Community Admin on 05-Dec-2012 00:00

Hello, I am receiving an error when I try to view the settings page for forums. the error is below:
Compilation ErrorDescription: An error occurred during the compilation of a resource required to service this request. Please review the following specific error details and modify your source code appropriately. 

Compiler Error Message: CS1061: 'Telerik.Sitefinity.Web.UI.Fields.HtmlField' does not contain a definition for 'ClientId' and no extension method 'ClientId' accepting a first argument of type 'Telerik.Sitefinity.Web.UI.Fields.HtmlField' could be found (are you missing a using directive or an assembly reference?)

Source Error:

Line 116: <asp:DropDownList ID="DropDownListInserts" runat="server" CssClass="sfAlignMiddle sfMRight5">
Line 117: </asp:DropDownList>
Line 118: <a onclick="$find('<%= templateEditor.ClientId %>').get_editControl().pasteHtml($get('<%= DropDownListInserts.ClientId %>').value);"
Line 119: class="sfLinkBtn sfChange sfAlignMiddle"><span class="sfLinkBtnIn">
Line 120: <asp:Literal runat="server" Text="<%$Resources:ForumsResources, Insert %>" /></asp:Literal></span></a>
Source File: /SfCtrlPresentation/_SFCT_/d22b0bd0b4fa2cbf592abe94b95112f9146f5986/ForumsSettingsView.ascx    Line: 118 
How do I resolve this problem?  I am running v5.1.

Posted by Community Admin on 10-Dec-2012 00:00

Hi Jeff,

Thnak you for using our services.

Can you please let us know if you have updated the .NET version of your framework, to 4.5 by any chance? Also is this behavior consistent under all browsers?

We have tried reproducing it on our side however the functionality seems to operate correctly. Just in case, can you please try mapping an external template for the Telerik.Sitefinity.Forums.Web.UI.Backend.ForumsSettingsView type.

For your convenience I've attached a copy of the modified template to this reply.

All the best,
Boyan Barnev
the Telerik team

Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items

Posted by Community Admin on 10-Dec-2012 00:00

The .NET framework V4.5 is NOT installed on the server.  I've tried it on the latest version of chrome, firefox, and Internet Explorer on windows and all had the same error.  I would expect this since it is a server error, not a client one.  I'll try to do the external template mapping and let you know how it goes.

This thread is closed