Nolics.ORMapper.Base.NolnetException: There is no data provi

Posted by Community Admin on 04-Aug-2018 13:15

Nolics.ORMapper.Base.NolnetException: There is no data provider for class Telerik.Personalization.Data.PersonalizationValue. Did you forget to connect?

All Replies

Posted by Community Admin on 10-Jun-2013 00:00


We have a sitefinity 3.7 installation with a custom membership provider and it has worked perfectly for many years. We're in the process of upgrading our user database and part of that change is changing some ID's from integers to Guids. 

I've made a very small change in our membership provider, changed an int to a guid to use the new ID's, and everything seemed perfect. We are now able to login to sitefinity with the new database table design, and everything works perfectly. 

So I push it from my local machine to our development environment, and I get this error. After an hour and a half of struggling to figure out the problem last Friday, I decided to restart the website in IIS, and that seemed to fix the problem and it worked on the Dev server. About an hour later, the error was coming up again with no changes to any files or the database what so ever, it simply decided to be broken again. And this time restarting the website, recycling the app pool, or even restarting the whole server has no effect on it. 

This puts a huge road block in our project, as we cannot deploy to live with this issue. Any help is greatly appreciated. 

To sum up: 
1. Changed one line of code in our custom membership provider that worked for years: 

reader.Filter.Add("ID", 0 , DBFieldType.SQLInt, DBCompare.NotEqual)<br>
reader.Filter.Add("ID", Guid.Empty, DBFieldType.SQLGuid, DBCompare.NotEqual)

2. Works perfectly on local machine. No problems at all. 

3. Copied to Development server, Nolics error. 

4. Restarted website, fixed issue for about an hour. The error was gone on Dev.

5. The error returned by itself, with no changes. Absolutely no idea what the problem is. 

Any help is really appreciated. It seems through Google that only two people have ever had this same issue, and they didn't seem to find a solution. 



Posted by Community Admin on 14-Jun-2013 00:00

Hello John,

We have replied in the support thread you had open on the same topic, however for your convenience, let me provide a follow up here as well.

Can you please check the following forum threads which discuss similar issues and let us know if the proposed solution help you resolve the issue on your side? and

In addition, can you please try deleting the temporary files on the server, and let us know if the behavior persists after applying the suggested steps in the forums and clearing the temporary internet files?

Boyan Barnev
Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items

This thread is closed