No admin user details with LDAP set up

Posted by Community Admin on 04-Aug-2018 16:14

No admin user details with LDAP set up

All Replies

Posted by Community Admin on 14-Jun-2013 00:00
I have recently taken over a new short term project at an agency and copied a clients database to a local machine however found that I am unable to access the sitefinity backend due to the LDAP set up, even after resetting the password and other associated fields that would normally reset an admin password in sf_users.

I have seen mention of an option to select between normal and LDAP on the login screen but I do not have this option.

I am using Sitefinity 5.1, any suggestions gratefully received as this is an urgent issue that needs to be resolved as it is only a short term project.

Posted by Community Admin on 19-Jun-2013 00:00
Hi,

Thank you for contacting us.

When LDAP is configured and the provider enabled, you will get a dropdown with the available providers:http://screencast.com/t/ouZ3uDsK8wt
 
In your project, it is possible that the default provider has been disabled and you can use only the LDAP. You can check this in the Security.config file found in the App_Data/Sitefinity/Configurations folder. If the Default provider has been disabled, the node will look like this:

<membershipProviders>
        <add enabled="False" name="Default" />
        <add enabled="True" name="LdapUsers" />
        <config:link name="OpenAccessMembership37Provider" path="migrationModuleConfig/membershipProviders/OpenAccessMembership37Provider" module="Migration" />
    </membershipProviders>

If this is the case, set Default to true and restart the application. After that you will have the drop down to select the providers.

I hope this information helps.

Regards,
Atanas Valchev
Telerik
Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
This thread is closed