Posted blog item showing multiple times at front-end

Posted by Community Admin on 04-Aug-2018 07:29

Posted blog item showing multiple times at front-end

All Replies

Posted by Community Admin on 21-Jun-2013 00:00

Hi,

What to do to fix the next problem?:
A blog post is created, but it is showing 3 times at the front-end(see screenshots), when I unpublish the blog post it's shown 2 times. What can I do to fix this problem?

Thx!


Kind regards,

Jelle Spaan | RedMatters.com

Posted by Community Admin on 26-Jun-2013 00:00
Hello,

This sounds like an odd issue. Have you customized the advanced filter settings for the blog post control? By default it will display the posts that are visible and live: http://screencast.com/t/eYVGjMENzh5y

As you know every item has 2 versions in the database master and live and when it is edited a third temp one is created. To get a better, please, check  the sf_blog_posts table in the database and check how many entries are there for that blog post. Also, you can check the visible column if it is 1 for all items.

Regards,
Atanas Valchev
Telerik
Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Posted by Community Admin on 26-Jun-2013 00:00
Hello Atanas,


Thank you for your reaction, for as far as I know the filter is not customized. What I forgot to mention is that in the past two years this only happened once, which was last week. I fixed the problem, but not the cause, by deleting the post and making a new one. For now we just hope it won't happen again, else I'll get back at it.




Regards,


Jelle Spaan | RedMatters
Posted by Community Admin on 27-Jun-2013 00:00
Which version are you running (curious)

...if it's a version before the OpenAccess L2 cache fix, I'd disable that to avoid the wierdness.  We've seen SOOOO many strange things when it was enabled.
Posted by Community Admin on 01-Jul-2013 00:00
Hello,

If you are using a version before 6.0, would it be possible to disable the L2 cache by going to Settings-Advanced-Data and set Enable Data Caching to False. Save and restart just in case. It would also be helpful if you could delete the post on backup of the project and recreate it. Also, if the issue persists, please, open a support ticket so we can examine the project locally.

Regards,
Atanas Valchev
Telerik
Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
This thread is closed