Bug with Module Builder

Posted by Community Admin on 04-Aug-2018 21:08

Bug with Module Builder

All Replies

Posted by Community Admin on 03-Oct-2013 00:00

Hi Team,

There is a bug with the module builder export functionality which requires your attention for the next build.

To reproduce the issue:

1- Create a new custom module using the module builder and name it "Relationships" as an example
2- Under Relationships module create an "Entity1Relationship" content type
3- Add another content type called "Entity2Relationship"
4- Activate the module
5- Export the module, the first thing you notice it doesn't set the right name for the zip which should be Relationships
6- Import it into another site and you will see that the Type Name of the content are completely different (check the documentation to see it)
While you would except Relationships in the namespace, you will see it's Entity (which sitefinity got from the name of the first content type)

Tested with 6.1.4600


Posted by Community Admin on 08-Oct-2013 00:00

Hello George,

Thank you for contacting us.

I repeated the steps you described, but unfortunately i was not able to reproduce this bug. I`ve tried in 6.1 4600 and 6.1 4700 without success. I`ve also recorded a video how I`m reproducing it and if you notice something I`m not doing right please let me know.

We really appreciate your help!

Vassil Vassilev

Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items

Posted by Community Admin on 08-Oct-2013 00:00

Hi Vassil,

Believe it or not, it only happens on one site. I tried reproducing it on a new instance but it worked as expected. I am not sure why it didn't want to work on that one site. Maybe because I had a bad day :) 

Sorry for the trouble. Let's cancel this thread as it's working properly. I will let you know if I find out more about it.



Posted by Community Admin on 18-Oct-2013 00:00

I'm having a similar issue. Did you upgrade the Sitefinity version from something else?
We also have a custom classification in the module we are trying to transfer? Or maybe it's a licensing issue?

This thread is closed