Page listing in backend - 404 page not found

Posted by Community Admin on 04-Aug-2018 10:32

Page listing in backend - 404 page not found

All Replies

Posted by Community Admin on 14-May-2014 00:00

Hi All,

I've been dealing with some really weird issues with Sitefinity since yesterday afternoon, most of which I've managed to resolve, but a new one of which is completely confusing me.

 Yesterday I was given a new project for a new website. Its going to be exactly the same as another of our sites, but with some additional content. To start with I decided just to create a test copy of our live website on a new server, so I backed up the Sitefinity database and restored it elsewhere with a new name, and copied all of the web files to a new server and changed the data config file to point to the new database. I've done this several times before with no issues, however yesterday afternoon our live website completely screwed up - pages were moved all over the place, were not showing up (even though they were visible and published in the backend), when we tried to move them back to their original location it would seem to work but still their URL included the wrong path, basically it was just mashed up. Finally I reverted to a backup of the web files late last night that I'd taken in the morning and everything went back to normal, phew.

 This morning I've attempted again to create the new test site, using the same method. The live site is now fine. The new site is working fine from a front-end point of view. However, I now have an issue where when I go into the sitefinity backend and click Pages, I get a javascript type alert saying "404 - file or directory not found". Its just trying to get to <siteroot>/sitefinity/pages. The database and web files are a complete copy of the live site except for the data config file which has a different connection string, yet the live site works fine. 

 Any ideas why it might not be able to show the page listing?

Thanks in advance.


Posted by Community Admin on 15-May-2014 00:00

Hello Damian,

In general the method you are using should work and in your particular case most likely some setting referencing the previous site has been set. Check under Administration >> Settings >> Advanced >> System >> ServicePath if you have set some base url

Please, ensure also that your IIS is configured according to this article:Configuring the IIS to host Sitefinity projects. In addition to that, ensure that Network Service has the appropriate permissions over all  the folders and files of your project.

I am also attaching the required features that need to be enabled.

Hoe this helps.

Vassil Vassilev

Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items

Posted by Community Admin on 15-May-2014 00:00

Thank you for the reply and information Vassil.

Unfortunately I couldn't even get into the administration section of the backend, although it showed the basic setting options it showed a 404 error, and it all went blank when  I tried to get to advanced settings.

However, I then followed your instructions for setting IIS up as it was a brand new server on Windows Server 2012 R2 (first web server we have on this version), and following this everything is working great.

Thanks again for your help.


This thread is closed