Can't upload images after 7.1 upgrade

Posted by Community Admin on 04-Aug-2018 13:32

Can't upload images after 7.1 upgrade

All Replies

Posted by Community Admin on 18-Sep-2014 00:00

After upgrading our project to 7.1, we are unable to upload images.  We are able to get into the image uploader and browse or drag-drop images, but after the upload completes there is a message box that says "  'MyImage.png' could not be uploaded.  MyImage.png "   An entry appears for the image in the target Library for the image, but the image itself is blank.

 One other thing to mention is that there is a javascript error that occurs while uploading.  This problem occurs across different browser types.

Posted by Community Admin on 18-Sep-2014 00:00

Solved.... The problem was in the web.config file, and was resolved by commenting out the line "<requestLimits maxQueryString="10000" />" as shown below.


  <location path="Telerik.Sitefinity.Html5UploadHandler.ashx">
      <httpRuntime maxRequestLength="6048000" executionTimeout="7200" maxUrlLength="102400" maxQueryStringLength="102400" requestValidationType="Telerik.Sitefinity.Security.Claims.CustomRequestValidator, Telerik.Sitefinity" />
          <requestLimits maxAllowedContentLength="2147483648" />
          <!--<requestLimits maxQueryString="10000" />-->

Posted by Community Admin on 03-Dec-2014 00:00

telerik:RadAsyncUpload not working after upgrading to Sitefinity 7.2.5320.0  

I am having similar issue, have been using telerik:RadAsyncUpload on one of our custom module though its no longer working.

Once image is selected it get stuck in uploading without doing anything.

Posted by Community Admin on 08-Dec-2014 00:00


So far we have not had other reports of the same issue. Would it be possible to send the control in ticket you have opened so we can try it on our end, please? Once we have resolved the issue, you can share the solution with the community.

Atanas Valchev

Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items

Posted by Community Admin on 14-Jul-2015 00:00

We're using version 8.0.5710.0 and are receiving the same error when attempting to upload images.

'Filename' could not be uploaded. Filename

A few months ago we performed an upgrade from 8.0.5700.0 to 8.0.57​10.0.



Posted by Community Admin on 14-Jul-2015 00:00

I found a more detailed message in the Developer Console saying, "Configuration element 'requestLimits' already defined". Like Compton, I found that I had the requestLimits element ​listed twice in the web.config but with different attributes.

<requestLimits maxAllowedContentLength="2147483648" />
<requestLimits maxQueryString="7200" />

I combined the attributes from the two elements into one element and can now upload.

<requestLimits maxAllowedContentLength="2147483648" maxQueryString="7200" />

Posted by Community Admin on 20-Oct-2015 00:00

Experienced the exact same problem but when upgrading to 7.3.

Resolved it by REPLACING web.config (entirely) with the web.config that comes in the 7.3 Empty Project.

This thread is closed