Can't search through (search widget) dynamic module cont

Posted by Community Admin on 04-Aug-2018 18:24

Can't search through (search widget) dynamic module content despite it being indexed

All Replies

Posted by Community Admin on 25-Sep-2015 00:00

Hello all, weird issue I'm having. I created a Search Index and enabled my Dynamic Content Items, then in Advanced, I gave a comma separated list of the fields I wanted search. Then I added a Search widget, and set it to the index I created, and I added a search fields widget on the same page (proof of concept) and set it's SearchFields and highlightfields properties to the comma separated list.


Unfortunately, this doesn't work. I try to search "Treme" which is in the title of one of the projects and I get no results back. I can only search static pages, Imagesand Documents. 



Posted by Community Admin on 30-Sep-2015 00:00


Can you please try to re-index the search index and test the behavior again?

You should not have problems to index the dynamic content items. I am also sending attached a short video for your convenience demonstrating this. In the video I configured the search to index the Tags filed, however the approach is the same with any other fields.

Can you please record a video demonstrating how you have configured this on your side and how the issue reproduces? This will help me to get better picture of the problem? Please also let me know your current Sitefinity version.

Sabrie Nedzhip

Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items

Posted by Community Admin on 30-Sep-2015 00:00

Hello thanks for the response. I followed the video exactly, and still had no luck. Interestingly, I tried this on another project and the search worked as it was supposed to. Could there perhaps be a way that the modules were built in Module Builder or an error in any configuration files that's preventing them from being indexed? 

This thread is closed