"Empty Stack" exception after upgrading; dynamic m

Posted by Community Admin on 04-Aug-2018 00:26

"Empty Stack" exception after upgrading; dynamic module changed field to nullable

All Replies

Posted by Community Admin on 03-Dec-2015 00:00

After running the upgrade process from 6.3.500 to 8.2.5905 I tried to visit the homepage but saw the following error:

Database mapped field uses different type 'System.Nullable`1[[System.Decimal, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]'.
Parameter name: methodCallExpression
Actual value was re-t.FieldValue("Sequence").

Changing the related widget code from GetValue<decimal> to GetValue<decimal?> resolved it, but I'm curious why this might have happened.

Secondly, when we tried to log into the backend, I got the exception:

Stack Empty

I unfortunately didn't capture the full error message, as I somehow resolved it by disabling BrowserLink, by adding the following config to web.config appsettings:

<add key="vs:EnableBrowserLink" value="false" />

after that everything seems to be fine, and removing that key does not bring the error back.

I'm not sure what happened, but logging it here in case it might be helpful to anyone else

thanks

Posted by Community Admin on 09-Feb-2016 00:00
I need a solution for this too
Posted by Community Admin on 11-Feb-2016 00:00
Hi ,

Josh, thank you for the shared solution.

Ilan, can you please provide more information about the issue you have (actions performed and the error received)? What is the result when apply the proposed solution?

You can also check the solution proposed in that KB article:
http://www.sitefinity.com/developer-network/knowledge-base/details/updated-data-base-type-of-numeric-custom-fields-after-an-upgrade-to-sitefinity-8.1

Regards,
Svetoslav Manchev
Telerik
 
Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
 
This thread is closed