Assembly reference issue - 'Mvc' does not exist in t

Posted by Community Admin on 04-Aug-2018 22:19

Assembly reference issue - 'Mvc' does not exist in the namespace "Telerik.Sitefinity.Frontend"

All Replies

Posted by Community Admin on 22-Feb-2017 00:00

First off, I am fairly new to development so I am sorry if this question sounds stupid or if I have a hard time following someones answer.

I have been trying to upgrade a Sitefinity website from 8.2 to 9.0 (with the intent to move up to 9.2) and I am using Visual Studio 2013.

Attached are a screenshot of the two errors and a screenshot of Telerik.Sitefinity.Frontend.Mvc.Infrastructure.Controllers.Attributes inside of Telerik.Sitefinity.Frontend.dll


A brief description of the process leading up to the error:
1.) I pulled the files from VS onto my local machine and updated the App_Data\Sitefinity\Configuration folder with the files from our production environment.
2.) I imported the local files into Sitefinity Project Manager - 9.0.6020.0 as a project and verified that the files worked locally (with the exception of some of the images being broken due to file path).
3.) I upgraded the project and checked again that the site worked locally. This also upgraded the development database.
4.) I built the project with no errors. Published the website to find 2 errors both related to the title of this thread. I also got 5 warnings which were all related to assemblies as well.

I have tried: - The target framework is set to 4.5 and there was no Telerik.Sitefinity.Frontend.Mvc... files in the empty project

This thread is closed