Invalid provider name "Default" for SitefinityMemb

Posted by Community Admin on 04-Aug-2018 18:40

Invalid provider name "Default" for SitefinityMembershipProvider specified in web.config file

All Replies

Posted by Community Admin on 09-Oct-2012 00:00
I'm getting the following error after updating a setting in the admin backend (changed the enable password reset flag to true) in my 5.1 project.

'Invalid provider name "Default" for SitefinityMembershipProvider specified in web.config file. The name should match one of the providers configured in Sitefinity's Security.config configuration.'

This is an emergency and need help asap. I can't get to any pages, frontend or admin backend. I restored a backup of the database but no change. I'm fairly certain it is in the config files. I checked the following config files:

web.config
<membership defaultProvider="Default">
      <providers>
        <clear/>
        <add name="Default" type="Telerik.Sitefinity.Security.Data.SitefinityMembershipProvider, Telerik.Sitefinity"/>
      </providers>
    </membership>

securityconfig.config
<membershipProviders>
        <add minRequiredNonalphanumericCharacters="1" newPasswordLength="7" passwordFormat="Encrypted" enablePasswordRetrieval="true" enablePasswordReset="yes" recoveryMailAddress="noreply@mossyoakobsession.com" name="Default" />
        <config:link name="OpenAccessMembership37Provider" path="migrationModuleConfig/membershipProviders/OpenAccessMembership37Provider" module="Migration" />
    </membershipProviders>


This thread is closed