Sitefinity with 4.7 issue

Posted by Community Admin on 04-Aug-2018 13:20

Sitefinity with 4.7 issue

All Replies

Posted by Community Admin on 24-Aug-2017 00:00

Hi,

 

A client of mine has Sitefinity. His hosting provider has upgraded .NET to 4.7 and now he has the famous error:

An item with the same key has already been added.

 This link (knowledgebase.progress.com/.../sitefinity-and-net-4-7-compatibility-issues) shows in which versions this bug has been fixed. However when I login and see my licenses screen, we can only download the following versions:

7.2 5320  
7.2 5310  
7.2 5300  
7.1 5200  
7.0 5100  
6.3 5000  
6.2 4910  
6.2 4900  
6.1 4700  
6.1 4600  
6.1 4300  
6.0 4210  
6.0 4200  
6.0 4100  
5.4 4040  

Does this mean that we have to pay for a new license just so we can fix this error?

Best regards

Posted by Community Admin on 24-Aug-2017 00:00
No, you need to click to "Internal builds" and then in drop-down choose major version.  After this steps it will show for you latest available internal build
Posted by Community Admin on 24-Aug-2017 00:00

Hi Victor,

That way I can indeed download the fixed version. However, my license files doesn't work in that version.

Posted by Community Admin on 29-Aug-2017 00:00
I still can't find a solution for this. I guess buying a new license again is the only option.
Posted by Community Admin on 29-Aug-2017 00:00

Have you opened a ticket with support?

I can't promise anything, but I usually do that when I do not get a response on the forums and it generally gets some kind of reply.

Posted by Community Admin on 30-Aug-2017 00:00
What do you mean by "my license files doesn't work in that version". Licence file for which version of Sitefinity do you have? It should work for you without buying new licence
Posted by Community Admin on 30-Aug-2017 00:00

@Brian: I can't open tickets. The system tells me that I have to buy a new license to get support.

@Victor: Each license file that I download says that the license file is invalid (see screenshot for available licenses)

Posted by Community Admin on 30-Aug-2017 00:00
And what is the version of website which is broken?
Posted by Community Admin on 31-Aug-2017 00:00

I am not sure about the exact version. It was 6.x I think.
I can upgrade to 7.2.5310 but that doesn't fix the problem, since the error will be also raised in that version.

Posted by Community Admin on 31-Aug-2017 00:00
You can check version in bin/Telerik.Sitefinity.dll file. Open properties and will show the version
Posted by Community Admin on 31-Aug-2017 00:00
You can check version in bin/Telerik.Sitefinity.dll file. Open properties and will show the version
Posted by Community Admin on 02-Sep-2017 00:00

The version is: 6.1.4700

My license allows me to download and upgrade to 7.2 5320, however the bug is still present in that version.

Posted by Community Admin on 02-Sep-2017 00:00

To make things easier,  please try to do the following:

1) In telerik portal download  Sitefinity Internal Build 7.2.5331.0

2) Download license from portal for version  7.2.XXXX

3) Upgrade your project with this instruction: docs.sitefinity.com/upgrade

4) Activate upgraded project with license downloaded from step 2

This thread is closed