Seeking Not Working in JWPlayer with Sitefinity uploaded vid

Posted by Community Admin on 03-Aug-2018 18:16

Seeking Not Working in JWPlayer with Sitefinity uploaded videos

All Replies

Posted by Community Admin on 01-Nov-2011 00:00
I'm using JWPlayer to switch between the HTML5 video player and Flash depending on the browser.  However, seeking does not work in the HTML5 video player after I've uploaded a video to Sitefinity.

I've tested referencing this video in the file system before uploading, and seeking works.  But, after uploading it to Sitefinity, it simply does not.  The mime type is coming back as video/mp4 in both cases.  I've also tried waiting until the video has completely loaded and then trying seeking to check if perhaps the video had not completely loaded.

I've also tried created a video library that uses the file system storage rather than the database storage, but still no seeking.  Based on the JWPlayer documentation, it seems there may be some meta data that has gone missing that is used for seeking.

Has this happened to anyone else or does anyone have any ideas what would cause this?
Posted by Community Admin on 03-Nov-2011 00:00

Hey Nerd,

It's not a JWPlayer issue, this happens with a regular html5 video tag aswell. 
If you take a look at the 1st screenshot (frontend.png) you'll see 2 html5 videos. The top one being the Video library file, the 2nd being a manually uploaded (outside of SF) videofile.

The first doesn't allow for seeking, the second does. Maybe some tools report both mime-types as video/mp4 but if you take a look at the Fiddler screenshot, you immediately spot the problem.

The library video's is served 200 as an octet-stream, the manually referenced one comes back as a 206 with video/mp4. (Also note the size difference, although they are the same video file the '206' is served proportionally).

Since library served files (db or filestorage provider) are served as an octet-stream, seeking will never work.

J.

This thread is closed