Specified cryptographic algorithm is not supported on this p

Posted by Community Admin on 03-Aug-2018 17:15

Specified cryptographic algorithm is not supported on this platform

All Replies

Posted by Community Admin on 23-Jul-2013 00:00

We have created a project with no problem but when we go to Administration we can get to the login page but when we try to login we get the error "The specified cryptographic algorithm is not supported on this platform"  If we use an incorrect login name or password we do get the error incorrect logn name or password. We get the cyrptographic alogorithm error only we were are trying to login with a correct user name and password.

We are using the same platform which we have created several projects on. We are using Sitefinity 5 on Windows server 2003. The project manager is being run from a mapped net work drive as we cannot run a web browser on our server. This has never been a problem in the past anyway. Have attached the error print out.

Rob

Posted by Community Admin on 26-Jul-2013 00:00
Hi Rob,
Thank you for contacting Sitefinity support.

Unfortunately this specified cryptographic algorithm (in this case SHA256) that Sitefinity use for encrypting is not supported in Windows XP and Windows Server 2003, although it is possible to overcome this by installing a hotfix. Look at this KB for more information
support.microsoft.com/.../938397.

However, it is recommended to upgrade your server at least to Windows Server 2008 or newer to avoid such kind of problems.

I hope this information helps. Please let me know if I can assist you any further. Thank you in advance

Regards,
Yavor Slavchev
Telerik
Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Posted by Community Admin on 26-Jul-2013 00:00
Hi Yavor,
   What I don't understand though is prior to the new project not working, one day before,  our other projects worked fine on the same setup, Server 2003 and running manager from a mapped drive.  It all worked prior to the new project and nothing changed where any of the files etc were located. Can't figure out why it only affected the new project.  If this particular algorithm was not supported the other projext should not have worked also I would think.


[quote]Yavor Slavchev said:Hi Rob,
Thank you for contacting Sitefinity support.

Unfortunately this specified cryptographic algorithm (in this case SHA256) that Sitefinity use for encrypting is not supported in Windows XP and Windows Server 2003, although it is possible to overcome this by installing a hotfix. Look at this KB for more information
support.microsoft.com/.../938397.

However, it is recommended to upgrade your server at least to Windows Server 2008 or newer to avoid such kind of problems.

I hope this information helps. Please let me know if I can assist you any further. Thank you in advance

Regards,
Yavor Slavchev
Telerik
Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
[/quote][quote]Yavor Slavchev said:Hi Rob,
Thank you for contacting Sitefinity support.

Unfortunately this specified cryptographic algorithm (in this case SHA256) that Sitefinity use for encrypting is not supported in Windows XP and Windows Server 2003, although it is possible to overcome this by installing a hotfix. Look at this KB for more information
support.microsoft.com/.../938397.

However, it is recommended to upgrade your server at least to Windows Server 2008 or newer to avoid such kind of problems.

I hope this information helps. Please let me know if I can assist you any further. Thank you in advance

Regards,
Yavor Slavchev
Telerik
Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
[/quote]
Posted by Community Admin on 31-Jul-2013 00:00
Hi Rob,

Thank you for contacting us.

Please note  that Windows XP is not supported platform for Sitefinity (Sitefinity System Requirements).
Could you please confirm that your Sitefinity project is hosted on Windows Server 2003, IIS 6 and you are trying to access the Sitefinity website via one of the supported browsers?
Please, note that if you run your project from the Sitefinity Project Manger it will start a process on your local machine, which in your case Windows XP and that will cause that issue.

I hope this information helps. Please let me know if I can assist you any further.

Regards,
Strahil Strahilov
Telerik
Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Posted by Community Admin on 01-Aug-2013 00:00

Hi Strahil,

  Double checked and yes the project is hosted on Server 2003 IIS6 and we are using IE 8 javascript allowed etc...  I guess what has me confused is Sitefinity was working on other projects in the exact same environment. For this project we have not changed a thing in the process or where any files etc reside. Project manager works to the point where if you click on admin it takes us to the backend login screen. When we try to login is when we get they error. If the error is platform related we should have been getting it before on the other projects I would think.

Rob

Posted by Community Admin on 05-Aug-2013 00:00
Hello,

Thank you for contacting Sitefinity Support.

Could you please execute the following two tests, which will help us to investigate the possible causes of the issue?
Could you please record a short video with the tests and upload it?


            Could you access the site via web browser (e.g. IE + your web site address)?
            NOTE: Please don’t use the Project manager for this test.

As the error states the cause if something missing on the operating system when sitefinity tries to execute its claims authentication this might be the cause if the other sitefinity site ran on this server were using forms authentication.

To check if other site ran on this server were using Forms authentication the entry for forms authentication in App_Data/Sitefinity/Configuration/SecurityConfig.config is:

<securityConfig xmlns:config="urn:telerik:sitefinity:configuration" xmlns:type="urn:telerik:sitefinity:configuration:type" config:version="6.1.4300.0" authenticationMode="Forms" authCookieName=".SFAUTH-/" rolesCookieName=".SFROLES-/" validationKey="F686A741719BFD24F8E15D94E1E505654721A28111D6360EAF209AC24AA758C9258DF5BC1FC30AD53153279E9D2F87032D2DCC677B93F6C6546ADA24D540ECEE" decryptionKey="21CF7920ECE7A579F4390E4E40D3D12D9349A861DBA08CE0C99F01A0851DE334" loggingCookieName=".SFLOG-/">

If the highlighted part of the configuration is missing the authentication is claims.

Regards,
Veneta Bogoeva
Telerik
Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
This thread is closed