Return Code: 0 Error

Posted by Community Admin on 03-Aug-2018 15:47

Return Code: 0 Error

All Replies

Posted by Community Admin on 08-Nov-2013 00:00
I have tried most, if not all, of the solutions in the forums unsuccessfully. This includes checking the VERBS in IIS, file permissions, database file sizes and restrictions and the base workflow URL in the advanced settings

It seems the PUT request is failing per the Network tab in Chrome. Also, there is "Failed to load resource message" in the javascript console. Any suggestions?

Request URL:BASEURL/.../ Headersview sourceContent-Type:application/jsonOrigin:BASEURLReferer:http:/.../ContentViewEditDialog (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/30.0.1599.101 Safari/537.36X-Requested-With:XMLHttpRequestQuery String Parametersview sourceview URL encodeditemType:Telerik.Sitefinity.Libraries.Model.DocumentparentItemType:Telerik.Sitefinity.Libraries.Model.DocumentLibraryOpenAccessDataProviderproviderName:managerType:provider:workflowOperation:PublishRequest Payloadview sourceAdditionalUrlNames:[/docs/forms/aof-(trust-pension-or-profit-sharing),…],…AdditionalUrlNames: [/docs/forms/aof-(trust-pension-or-profit-sharing),…]AdditionalUrlsRedirectToDefault: "false"AllowMultipleUrls: "true"DefaultUrl: "/docs/forms/trust-pension-or-profit-sharing"Item: AllowComments:true, AllowTrackBacks:null,…ItemType: "Telerik.Sitefinity.Libraries.Model.Document"


Posted by Community Admin on 08-Nov-2013 00:00
It was permissions. I'm using a specific user for the application pool identity and this user was given access to the App_Data folder with Modify permissions. This did not seem to work at first even after an IIS reset but I tried it in IE and it seemed to work. May be delayed due to caching perhaps.

AC
Posted by Community Admin on 21-Nov-2013 00:00
And it seems the issue is not resolved yet. I was using a single document to test this issue and while I am able to rename this document, changes to the properties of any other document are returning the same error message.

This is extremely frustrating.
Posted by Community Admin on 22-Nov-2013 00:00
Hi,

Would it be possible for you to review whether you have configured IIS correctly following our documentation:

www.sitefinity.com/.../configuring-the-iis-to-host-sitefinity-projects

Furthermore, please take a look at this blog post:

http://www.sitefinity.com/blogs/teamblog/posts/team-blog/2011/02/22/installing_sitefinity_4_on_iis_7

Could you please configure WorkflowBaseUrl? The property could be found in Administration -> Settings -> Advanced -> System -> ServicePaths. You could find more information below:

http://www.sitefinity.com/developer-network/knowledge-base/pages-cannot-be-published-after-installation

If the problem still persist could you please delete all error logs (~\App_Data\Sitefinity\Logs) and after that reproduce the issue again and set the logs to us?

Regards,
Stefani Tacheva
Telerik
Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
This thread is closed