You do not have a permission to access "/Sitefinity&quo

Posted by Community Admin on 03-Aug-2018 11:04

You do not have a permission to access "/Sitefinity". Contact your administrator for more information.

All Replies

Posted by Community Admin on 10-Nov-2016 00:00

We can't login on sitefinity backend even the admin account it shows the same issue. and below is last section of the error log. Please help.

 

Timestamp: 11/10/2016 11:02:17 AM

Message: HandlingInstanceID: 68bef921-5cef-4d9d-9f7f-319f392128d8
An exception of type 'System.Web.HttpException' occurred and was caught.
------------------------------------------------------------------------
11/10/2016 15:02:17
Type : System.Web.HttpException, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a
Message : File not found.
Source : Telerik.Sitefinity
Help link : 
WebEventCode : 0
ErrorCode : -2147467259
Data : System.Collections.ListDictionaryInternal
TargetSite : IOutputItem GetOutputItem(System.Web.HttpRequestBase, System.Web.HttpResponseBase, Telerik.Microsoft.Practices.EnterpriseLibrary.Caching.ICacheManager, System.String, Telerik.Sitefinity.Libraries.Model.MediaContent ByRef)
HResult : -2147467259
Stack Trace :    at Telerik.Sitefinity.Modules.Libraries.Web.LibraryHttpHandler.GetOutputItem(HttpRequestBase request, HttpResponseBase response, ICacheManager cache, String key, MediaContent& content)
   at Telerik.Sitefinity.Modules.Libraries.Web.LibraryHttpHandler.ProcessRequest(HttpContextBase context)
   at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
   at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

Additional Info:

MachineName : DIRECTSRV
TimeStamp : 11/10/2016 11:02:17 AM
FullName : Telerik.Sitefinity.Utilities, Version=7.0.5100.0, Culture=neutral, PublicKeyToken=b28c218413bdf563
AppDomainName : /LM/W3SVC/4/ROOT-8-131232482732190703
ThreadIdentity : 
WindowsIdentity : IIS APPPOOL\ASP.NET v4.0
Requested URL : /images/mobnavbg.png


Category: ErrorLog

Priority: 0

EventId: 90000

Severity: Error

Title:Enterprise Library Exception Handling

Machine: DIRECTSRV

App Domain: /LM/W3SVC/4/ROOT-8-131232482732190703

ProcessId: 4808

Process Name: c:\windows\system32\inetsrv\w3wp.exe

Thread Name: 

Win32 ThreadId:5700

Extended Properties: 
----------------------------------------

Posted by Community Admin on 14-Nov-2016 00:00
Sometimes I had the same issue.  Recycling of application pool is working for me.
Posted by Community Admin on 15-Nov-2016 00:00
I tried it and still the same. I checked in the database, user table, it is set to backend_user False. I switched it to TRUE and try logging in again then going back to the database, it is back to False again.
Posted by Community Admin on 16-Dec-2016 00:00

Running into the issue as well after updating to 9.2.6200

Tried to set is_backend_user to TRUE, but it too reverts back to FALSE when trying to log in.

Was there a solution found for this?

Posted by Community Admin on 14-Jun-2017 00:00

We had this issue using database configs and multisite.

In [sf_xml_config_items] table the value for ProjectConfig had an invalid defaultSiteId inside a <defaultSite> element.  We removed the incorrect <defaultSite> element from the xml config in the table, and then the correct settings in the ProjectConfig.config file came through and logins were restored.  It does seem to remove permissions as well as set is_backend to false, so we had to create a new user by manually manipulating the table to fix.

This thread is closed