v11 Procedure Library issue

Posted by robmaslen on 31-May-2012 09:49


When I try to start a webspeed broker that contains my v11 procedure libraries in the propath I get this error:

   [12/05/31@11:52:57.091+0100] P-28311732 T-000001 1 WS -- Corrupted directory structure in library psescript/pseweb.pl. (1935)

I can't find any documentation on this error and have checked everything that seems relevant so very would appreciate any help getting it to work!

I'm creating v11 .pl files by compiling the relevant .p code using the v11 appbuilder, then using these commands in v11 proenv:

   PROLIB -pseweb.pl -create -codepage undefined

   PROLIB -pseweb.pl -add webpse/*.r

Is this process correct?

I used "-codepage undefined" as the only difference I could see between v10 and v11 was that the v11 defaulted to a code page of iso8859-1. See attached screenshots for results of "PROLIB -pseweb.pl -list" on both versions.

When I do the same process with v10 tools the resulting pse.pl file works ok. I also tried adding just one .r file at the root directory but that has a corrupt directory structure too.

I tried "PROLIB pse.pl -verbose" since that's meant to tell you what's being done by PROLIB but it didn't add any more information.

Any ideas please?



PS. This probably doesn't help but... WinPL (v1.4) can open the v10 pse.pl but it errors on v11 saying: "Not a valid archive format !".

All Replies

Posted by robmaslen on 01-Jun-2012 04:25

The Progress support guys solved this. I was FTPing the files from Windows to Linux in "auto" mode which must have been evaluating to ASCII and was causing the problem.

Changing the FTP transfer mode to binary and re-transferring the files solved it.

This thread is closed