IntelliSense in PDS for OpenEdge.Net.HTTP objects

Posted by slacroixak on 29-Jun-2019 07:31

The OE 11.7.5  PDS does not seem to provide IntelliSense (completion for properties and methods) for OpenEdge.Net.HTTP objects

I am missing an xml file somewhere or something else?

All Replies

Posted by Keerthy Yeddula on 01-Jul-2019 12:12

Hi slacroixak,

This works fine when I try this for an OpenEdge project. It must be an issue with the specific setup. Can you please try the following and let us know?

1. In a new workspace create an OpenEdge project and try following.

• Create a procedure file, declare a class variable from OpenEdge.Net.HTTP library, instantiate the class and check if properties and methods are listed in content assist

2. Try Refresh Cache from OpenEdge menu and let us know if it works.



Posted by slacroixak on 01-Jul-2019 15:27

Hi Keerthy, many thanks for your input.

1.a) With a new WorkSpace and a new OpenEdge Project in it, the completion works fine for variable of type OpenEdge.Net.HTTP.IHttpRequest.

1.b) However, In my existing workspace, even if I create a brand new OpenEdge project with default for everything, it does not work.

2) I have tried the Refreh Cache action from the OpenEdge Menu for case 1.b) without much success. Same result if I launch the PDS with the -clean Eclipse option.

Now, I have to say I first made this Workspaces and its 3-4 projects with OE 12.0 about a month ago.  After one week, we realised we cannot yet go OE12 but with 11.7 for medium term (we need a version that supports both Classic and  PASOE AppServers...) , so I made a copy of the OE12 Workspace, and started to open the Workspace with 11.7.  Yes, there was a warning about using 11.7 for something made in 12.0.  I believe I had to refine a few config bits in the project properties, but everything is compiling and running fine with it (for simple client stuff as well as PASOE stuff). A couple of weeks ago I upgraded my 11.7.4 to 11.7.5 as SP5 was released.

This week-end, I realised for the first time that intellisense is broken for OpenEdge.* objects.

I confirm Intellisense works fine for my own ABL types, as well as for native .Net types like System.Text.RegularExpressions.Regex

Any hit to fix this issue?  One project is a OpenEdge/Server project with quite a few things in it already, and I would like to avoid redoing it all from scratch.

Best regards


Posted by slacroixak on 02-Jul-2019 05:09

Additional info:    completion also broken for this OpenEdge.Core.System.ErrorSeverityEnum:  (I should see Error, Critical, Warning etc... members)

At last, if I export a project an reimport it in a brand new Workspace, then the problem gets solved.  I may just go with that...

Posted by Ramadevi Dhavala on 05-Jul-2019 12:17


Can you please give one more try by deleting the ".index" files from  "$WorkspaceLocation\.metadata\.plugins\com.openedge.pdt.project " and relaunching PDS with the -clean option?

Thanks & Regards,


Posted by slacroixak on 14-Aug-2019 13:39

Hi Ramadevi, sorry for missing your post.  I have deleted the offending project since then

This thread is closed