OE12 change the default promsgs

Posted by Andrzej.Sz on 07-Jun-2019 15:39

How to change the default promsgs for all sessions?

KB: https://knowledgebase.progress.com/articles/Article/P68929

I've stopped database, PAS and AdmService but promsgs is still opened by OE Management Service.


All Replies

Posted by Andrzej.Sz on 07-Jun-2019 16:30

I've tried to stop fathom in proenv "fathom -stop" command too. It is rejected with system error 5 (access denied).

Posted by Matt Baker on 07-Jun-2019 16:34

Are you asking about OEM?  it respects the PROMSGS environment variable (at least in recent 11.x versions it does) and 12.x.

There isn't a good way through the windows services UI (as far as I know) to set environment variables.  Since you mention separate AdminServer and OEM service I'll assume you are on 12.x.  You can use the $OEM/bin/fathom_setenv.[bat|sh] file to set extra environment variables for OEM.  You'll need to un-register and re-register the service (sorry this is a tomcat thing) for the change to be picked up.  

Posted by Matt Baker on 07-Jun-2019 16:36

In 12.x fathom now uses the windows 'net' command to start/stop the service.  To do this you need windows administrator privileges.  To get them open cmd.exe (or powershell i you want) with elevated privileges and then start $DLC/bin/proenv.  Then run fathom and you can start/stop without the privilege error.

Posted by Matt Baker on 07-Jun-2019 16:50

Some instructions:

open a command shell with elevated privileges

start a proenv session:


Check OEM service status:

proenv>%OEM%\bin\tcman service status

Stop OEM

proenv>%OEM%\bin\tcman service stop


proenv>fathom -stop

using an editor open %OEM%\bin\fathom_setenv.bat

add in the set PROMSGS =<...whatever you what...>

Save the file and exit

unregister the service

proenv>%OEM%\bin\tcman service unregister

re-register the service (the two environment variable lines restore the human readable name and description...the can be anything really, or left out if you don't care)

proenv>set PR_DISPLAYNAME=OpenEdge Management Service for OpenEdge 12.0

proenv>set PR_DESCRIPTION=OpenEdge Management Service for OpenEdge 12.0

proenv>%OEM%\bin\tcman service fathom_12.0 register

start OEM

proenv>%OEM%\bin\tcman service start


proenv>fathom -start

tcman uses Tomcat's windows registry tool to register services.  OEM uses PAS as it's webserver foundation and can take advantage of this.  But when tcman does the registration the environment variables and system properties are all copied into the windows register, which requires registration if anything is changed.

Posted by Matt Baker on 07-Jun-2019 16:56

couple more items:

Also set this environment variable before doing register.  otherwise it won't auto start when the machine is rebooted (or leave it out if you want manual startup)

proenv>set PR_Startup=auto

You can also control the JVM if you choose by setting JAVA_HOME before doing the registration. Otherwise it will just use whatever is setup for proenv.

proenv>set JAVA_HOME=<full path to java>  typically this would be something like %DLC%\jdk

Here is the doc on tcman register for reference:


Posted by Andrzej.Sz on 07-Jun-2019 20:01

I've stopped FATHOM with administrator privileges ( knowledgebase.progress.com/.../Openedge-12-fathom-won-t-start ) . Then copied "promsgs.pol" to "promsgs". Command "fathom -start" didn't execute because of error "The Fathom web application failed to start within the specified amount of time". I've reset the default promsgs and fathom started without problems.

This is the explanation of my installations problems with "polish" language as default, I think. I had to install OE12 with other (american) language as default, to be able to start OE Explorer. I'll try with environment parameters.

This thread is closed