OE SQL Client Access expired?

Posted by ledniczky.robert on 14-Feb-2019 07:53


I have a linux webserver where i use openedge odbc driver (10.2B) to connect to progress db. I use it for a long time, normal licenese with no expiration date, user limit for one. And recently when access database through php script for sql read I get the same error like in thes article:


I went  through resolution and everything is set right, except for LD_LIBRARY_PATH was empty (the server is Debian 8) but itt worked before. Anyway if I set LD_LIBRARY_PATH nothing changes, same error.The only thing I can do is copy the same licence file worked before into the foder of the php script (multiple folders actually where i run sql queries) then i get no error message.

The first i saw this error was when a cron job was set running every 5 minutes querying data from progress. Then i managed to run the script from the folder where odbc driver is present in cron (/usr/dlc/odbc) and it worked. Then after two weeks working fine, other php web scripts are falling down with the error.

Do you have any idea why this could be? I hope i was able to explain the problem well.

Thank You very much for Your help!

All Replies

Posted by Rob Straight on 25-Feb-2019 15:53

It would be best to bring this to the attention of the Progress Technical Support team, so we can formally investigate and assist you.

Posted by ledniczky.robert on 27-Feb-2019 06:57

Yes, but it's a bit difficult. In my company we have an ERP built on progress, and another company that provides support for it and etc.. And of course we asked them, but they are a little ..khm.. slow, so I asked it here too because maybe somebody met this kind of problem.

Thanks anyway!

This thread is closed