The pstimer.ocx file is suddenly deleted on an OpenEdge 32 b

Posted by mikaelstenmark on 15-Dec-2017 04:44

For four of our users, the pstimer.ocx file has suddenly been deleted. Because pstimer is used by our application, it does not start. Instead, some error messages indicate that the file is missing some. We use a VDI solution and no installation or upgrade of OpenEdge was made in conjunction with the file being deleted. However, an upgrade of Java was made. I tried to copy the missing file to the machine that was missing the pstimer file. But our OpenEdge application did not start yet. I compared regestry between a machine one with a working installation with the machine where the file was removed, and they were the same. I did not see that any regestrypost was missing. When I installed OpenEdge about the machine, our application worked as it should.

Is there anyone who has encountered this problem.

/Mikael Stenmark

All Replies

Posted by Roger Blanchard on 15-Dec-2017 06:10

We have seen that in the past and I am pretty sure it was due to antivirus software.

Posted by Brian K. Maher on 15-Dec-2017 06:34

Hi Mikael,
I have no idea why it was deleted and doubt that updating Java had anything to do with it.
Did you re-register the ocx after copying it?

Posted by mikaelstenmark on 15-Dec-2017 06:45

Thanks for the reply. We also suspected it could be our antiviral program but the tests we did left the file intact.


This thread is closed