Run char client over SSH on Cygwin fails with (156)

Posted by on 23-Jun-2017 08:07

Cywin is running on a Windows machine to allow a unix like working style.

Wenn I connect with Putty and start a char client I get "Redirection or piping of stdin or stdout is allowed only with -b. (156)"

KB says:

I tried different clients (Hyperterminal, SmartTTy). Hyperterminal is the trial version of HyperAccess, named in the KB entry as working.

I tried also local telnet server of Microsoft.

  • With Putty does not work
  • With windows telnet as Administrator it works

But we would like to have an SSH server, so I would kindly ask, if someone has a working combination of SSH server and SSH client for a windows host?


All Replies

Posted by Scott Dulecki on 23-Jun-2017 08:34

That error message makes me think that your client script is doing redirection… something like
_progres > logfile
Or something like that.  Check your client script to see exactly what’s being executed when you get to that stage.
Or start with just running _progres and expand from there.
Good luck.
Scott M. Dulecki                   MPUG 19 Jul
Progress                          WMPUG 20 Jul
616/481-4313                   SEUG 17-19 Sept            MWUG 8-10 Oct

Posted by gus bjorklund on 23-Jun-2017 16:18

> On Jun 23, 2017, at 9:08 AM, wrote:


> combination of SSH server and SSH client for a windows host?

try MobaXterm. I have switched to using that instead of putty when I must ssh from a Windows system.=

Posted by ChUIMonster on 23-Jun-2017 16:47

If I understand properly Klaus is trying to connect IN to the Windows box.

Posted by gus bjorklund on 26-Jun-2017 12:36

right. and MobaXterm will give you a server to connect with as well as the client. and lots of other useful stuff.

This thread is closed