PCT - PCTConnection

Posted by Elsworth Burmeister on 05-Oct-2016 02:19

Hi guys

Im working on a script using PCT to compile my programs code.

However im batting to establish a DB connection using the PCTConnection statement as my DB is started up with the

-Mm parameter set to 10240.

Ive tried using the param file aswell but still no luck.

params.pf contains the following:

-H test -S test -U test -P test -Mm 10240

<PCTConnection dbName="test" logicalName="test" paramFile="${par.dir}\params.pf" />

ERROR - 

[PCTCompile] Unable to connect to -db test-pf C:\ProgramMaintenance\PCT\params.pf -S 9068 -ld test -H test -U test -P test
[PCTCompile] Server has -Mm parm 10240 and client has 1024. They must match. (1150)

 

Seems that the -Mm hasnt even been picked up??

 

Can anyone provide some direction on how i can do this?

 

TIA

 

All Replies

Posted by riverside on 05-Oct-2016 03:14
-Mm is a session parameter, and is set in PCTRun ; see msgBufferSize attribute.

Gilles

Posted by Elsworth Burmeister on 05-Oct-2016 03:55

Hi

Thanks but i dont know how this will work in my situation?

im currently doing this.. and it fails in the DB connection

<PCTCompile destDir="${b1.dir}" dlcHome="${env.DLC}" relativePaths="true" assemblies="${ass.dir}">

 <!-- DB Connection -->

 <PCTConnection dbName="test" logicalName="test" hostName="test" dbPort="9068" userName="test" password="test" singleUser="false" />

 <!-- Source Code -->

 <fileset dir="${s1.dir}">

   <include name="**/*.cls"/>

   <include name="**/*.p"/>

   <exclude name="**/aps361dl.p"/>

   <exclude name="**/aps391i.p"/>

 </fileset>

 <!-- Propath -->

 <propath>

   <pathelement path="${b1.dir}\Creditors" />

 </propath>

</PCTCompile>

Form what is see this PCTRun command does not support the PCTCompile command in the documentation?

What do i need to get this compile script working with the PCTRun command that caters for this -Mm command??

Any suggestions would be appreciated.

Thanks

Posted by Simon L. Prinsloo on 05-Oct-2016 04:02

PCTCompile is a sub-class of PCTRun, so you need to specify the attribute msgBufferSize="10240" on <PCTCompile...>, not <PCTConnection...>.

Posted by Elsworth Burmeister on 05-Oct-2016 04:03

Hi

I solved the issues.... figured out that pctrun is the base class for pctcompile and so we just had to add the parameter msgBufferSize to pctcompile command.

Thanks.

This thread is closed