ActiveX Controller Issue

Posted by Kushal Basnet on 03-Aug-2016 07:21

Hi Guys, 

Well,  there is this one simple script that is used to generate an Excel Report using the COM-HANDLE (ActiveX Controller). It is very simple script to generate excel report which you can find in knowledge base too. 

The problem is when i run the script in Procedure Editor, Excel is generated flawlessly but when i do the same through the appserver connection, Following error occurs which can be found in appserver.log file. 

[16/08/03@12:36:21.868+3200] P-001080 T-012364 1 AS -- (Procedure: 'Excelinit Excel-Example.p' Line:71) Error occurred while accessing component property/method: Add.

Amazing thing is , when i do the same with another version of progress (Progress 11.5), it works fine !!!!

Currently i am using progress 11.6 version, and MS Excel is Genuine. MS Excel 2007. 

All Replies

Posted by Brian K. Maher on 03-Aug-2016 07:26

You say this code runs on the AppServer.  Is the AdminService running under the LocalSystem account?  If so, try another account with all the privileges needed (or just try using Administrator account for a quick test).

Posted by tbergman on 03-Aug-2016 10:21

I’m not sure if this is your problem but to have Excel run properly from a service you may need to add a folder to the server and may possibly need to login under the user account that starts the service (in this case the appservers) and run excel once interactively.
The folder that needs to be added is C:\Windows\System32\config\systemprofile\Desktop. There may be another possible folder needed depending on 64 vs 32 bit OS and Office. See the URL below for more info. This folder is the one we needed to add for 64 Bit Windows, Office and Progress.

Posted by Kushal Basnet on 16-Aug-2016 05:21

Thanks for your Help , But i was unable to even run a Script over app server (weather the appserver was stared from admin or non-Admin profiles).

Likewise, all the steps explained (i.e. adding folder to C:\Windows\System32\config\systemprofiel\Desktop) have been tried , but no solution found :( .


This thread is closed