OE Broker fails to start SQL server

Posted by Costel Niculae on 24-Mar-2016 03:00


I have 2 HP-UX servers with Progress 10.2B installed on them and if i run sqlexp on both machines with the same db for one of them works and for another not works.

I have the same startup parameters for the databases. Please help me with some ideas, what can be wrong?

Thank you,


All Replies

Posted by cSocaciu on 24-Mar-2016 03:26

Please check that in the database configuration for defaultServerGroup you have enabled both type of clients.

Posted by Costel Niculae on 25-Mar-2016 14:00

I checked the installations and i found that on the server for which the sqlexp doesnt work, is installed "OE DataServer for Oracle". This component can have impact with the sql ?

Posted by gus on 25-Mar-2016 14:18

when you say "sqlexp doesnt work", what symptoms of doesn't work do you observe?

Posted by Costel Niculae on 26-Mar-2016 00:00

In SQLExplorer.exceptions i received:

 Exception at Thu Mar 25 10:47:43 CDT 2016: java.sql.SQLException

  Message (throw): ### Connect stack trace. ###

  Message (excp):  [DataDirect][OpenEdge JDBC Driver]OE Broker fails to start SQL server.

  Stack Trace:

java.sql.SQLException: [DataDirect][OpenEdge JDBC Driver]OE Broker fails to start SQL server.

at com.ddtek.jdbc.openedgebase.BaseExceptions.createSQLException(Unknown Source)

In db log:

BROKER  0: (8841)  SQL server process terminated.

When i tried to use ODBC Progress OE Wire 7.1 i received:

..[OPENEDGE]Broker rejects connection.

I used 1 broker (4GL/SQL) or 2 brokers (one for 4GL and secondary for SQL) and in promon i saw that SERV can be started. But whatever i did SQSV is not running. I used the same logic on test server and works, but in production servers i cant use odbc.

This thread is closed