Error 9258

Posted by Riverside Software on 29-Jan-2016 06:40

Hello all,

Friday morning problem (with OE11.6 Linux 64 bits).

I've created a new utf-8 DB (with procopy $DLC/prolang/utf/empty foo), started a broker (proserve foo -S xxx -cpinternal utf-8 -cpstream utf-8). Then when I try to connect an iso8859-1 client (_progres -db foo -H localhost -S 10000 -cpinternal iso8859-1 -cpstream iso8859-1), I don't have a problem. But when starting a shift-jis client (using -cpinternal shift-jis -cpstream shift-jis), I'm getting this message :

Unable to open word-break table file 253. (2736)
The word-rule file specified by the -ttwrdrul parameter is invalid. (9258)

Using the 11.5 client with the same command line works perfectly. Is this a bug, or an issue in my configuration ?



All Replies

Posted by Riverside Software on 29-Jan-2016 06:50

In fact, it's not even related to the DB, starting the client without any DB connection fails with the same error message.

Posted by George Potemkin on 29-Jan-2016 07:08

In the 11.5 dlc directory you have the proword.253 file but not in 11.6 directory.

Posted by Fernando Souza on 29-Jan-2016 07:10

It's it not for the db, but for the temp-table db. Are you specifying the -ttwrdrul parameter (explicitly or in some .pf)?

Make sure you have the file proword.253 under $DLC.

Posted by Riverside Software on 29-Jan-2016 07:29

The in $DLC doesn't specify anything more than the default value. PROSTARTUP environment variable is not set. No -ttwrdrul at all in my command line.

I don't have a proword.253 in my 11.6 directory (as well as in my 11.5 directory).

The same command line on Windows on a different host gives me the same result. Could anybody try executing  `_progres -cpinternal shift-jis -cpstream shift-jis` with a 11.6 install ?

Posted by Aidan Jeffery on 29-Jan-2016 07:52

proword.253 is for shift-jis. The standard file for utf-8 is proword.254.
I believe the install only puts proword.254 in $DLC by default.

Posted by Valeriy Bashkatov on 29-Jan-2016 07:54


You need to download the Supplemental PROMSGS package from Progress Download Center which contains additional default compiled word-break tables, including the one that you need.

proword.253 you will find in the directory jpn/

Then copy jpn/proword.253 to $DLC and try again to connect.

Posted by Fernando Souza on 29-Jan-2016 08:12

The 11.6 behavior is due to a bug fix so that we set the word-break table correctly based on the -cpinternal value. As Aidan pointed out, proword.253 is the file for code-page shift-jis. You will need to have it installed under $DLC to be able to set -cpinternal shift-jis.

Posted by Riverside Software on 29-Jan-2016 08:16

Thanks for the explanation ! I've downloaded the proword.253 file from ESD, and it now runs without any problem.


This thread is closed