Problems with Webspeed under Linux.

Posted by rogeliolt on 07-Aug-2015 14:06

Hi friends, I have a doubt about the configuration of Webspeed and Apache Server.

I follow all the instructions of this link
but, when I tried to test the service, via URL, Firefox, send me a request to donwload the wspd_cgii, but not the webpage...

Can you help me, please.


All Replies

Posted by Ruben Dröge on 08-Aug-2015 03:29

Did you enable / configure Apache to permit CGI? If not, please check this link for a how to:

Posted by TheMadDBA on 08-Aug-2015 10:44

Maybe it was a typo but the CGI file name is and not wspd_cgii.

Posted by rogeliolt on 10-Aug-2015 12:35

It's true, but I wrote in the URL bar http://localhost/cgi-bin/ and I have the same result... Firefox send me a request to download the script.

Posted by Ruben Dröge on 10-Aug-2015 12:45

Didnt't think that was it anyway :) Did you check CGI permissions / execute rights?

Posted by Roy Ellis on 10-Aug-2015 12:59

Can you go to the "Open Menu" --> Select "Developer" and then select "Network" and see what that returns?  Can you also check the Apache logs and the WebSpeed Messenger log (msngr.log)?

Also if you download the file, is it indeed the script?

As Ruben states, it looks like the browser is seeing a file to download instead of the web server executing the  Execute permissions on either the file or in the Apache config is the most likely problem.

Let me know, Roy

Posted by rogeliolt on 10-Aug-2015 13:00

You had reason... the problem was the CGI conf. Now, I can use the webspeed with apache.

Thank you.

This thread is closed