PDS 11.5 evaluation SQL connection issues

Posted by kevin_saunders on 05-May-2015 08:38

Running on Windows 7, 64 bit. I've installed OE 11.5 eval (32 bit) so I can show my client a few things while we wait for their upgrade to be processed.

I've set up a local DB and served it, but my SQL connection won't connect. There's nothing in the DB log regarding a connection request. I've set up Squirrel SQL client and that connects just fine. In the progress log of PDS, I only see: "Connecting via SQL to 'Sports' "

Connection string looks like this: jdbc:datadirect:openedge://localhost:12345;databaseName=Sports2000


All Replies

Posted by cverbiest on 05-May-2015 08:45

Maybe beside the question but do you need the SQL connection.

I turn it off for most databases in PDSOE. Most ABL functionality uses the ABL connection

Posted by kevin_saunders on 05-May-2015 09:14

Not necessarily, but I do use it a fair amount.

However, it doesn't look great being as I've just convinced the client to upgrade.

Posted by cverbiest on 05-May-2015 10:13

I agree, only mentioned it because it may make the issue less blocking/urgent.

Posted by steve pittman on 05-May-2015 11:52

I just want to clarify that this problem seems to reside in PDSOE and its sql connection capabilities.

The fact that you can successfully connect from Squirrel shows that the db and OE sql are doing OK.

Hopefully, someone with PDSOE expertise can contribute some ideas.

...steve pittman   [OE sql software architect]

Posted by DivyaTheja on 05-May-2015 21:09

Hello Kelvin,

Are there any errors in PDSOE's error log? Error log can be found at <workspace location>\.metadata\.log.


Posted by kevin_saunders on 06-May-2015 05:04

Hi Divya,

Thanks for that - the log didn't show any SQL specific errors, however it showed an error regarding our proxy server (I had modified it to get Subclipse installed). I've set the Active Provider (Preferences -> General -> Network Connections) back to "Native" and I can now connect via SQL just fine.

Once our upgrade has been supplied, I'll reinstall and test it again and log a bug if it's still an issue (it shouldn't be as this setting is only supposed to affect http/https traffic).


This thread is closed