Problem with WSA and Tomcat

Posted by goz on 27-Feb-2015 08:40

We are migrating our 10.2A application from Win Svr 2003 to Win Svr 2012. We use Tomcat and WSA Web Services , it works perfectly in win 2003 and Tomcat 6.0, but now with Win2012 and Tomcat 8.0.18 so are we having problems. When I open OpenEdge Management and intend to deploy the web services so is all alternatives regarding that greyed out, I can only chose coniguration, log file and enable, all other alternatives is not possible to use. Any ideas any1?

All Replies

Posted by Ruben Dröge on 27-Feb-2015 08:55


Are you using the built-in Tomcat server of OE or are you running a seperate instance?

What URL is your WSA configuration pointing to (i.e. http://localhost:8980/wsa/wsa1)?

Is the wsa folder available there? Also make sure you have enabled web services on the 'Security' folder in the WSA configuration.

Posted by James Palmer on 27-Feb-2015 08:59

It's probably not directly related but we're in the process of the very same server OS migration and we've found that the way 2012 handles security means you have to really set the permissions you need in the local security policy to get OEM things working. Good luck with the migration!

Posted by tbergman on 01-Mar-2015 18:08

Jeff - Thanks for the suggestion. We already use the server name, not localhost in the connection string.

Jim - I think I found the post you mention but didn't see any link to more information. Anything you've got would be helpful.



Posted by James Palmer on 02-Mar-2015 02:17

Hi Tim,

This was the thread:

Libor kindly linked to this KB article.


Posted by goz on 02-Mar-2015 02:21

Hi again, thanks for all suggestions.

We use a separate instance of tomcat, we have several parallell wsa configurations and they point correctly and we have a wsa folder for each,

As i mentioned erlier this worked on win2003 but not now.

James -  your suggestion seemed a likely one but what permissions... The Firewall seems to be correct.

Posted by James Palmer on 02-Mar-2015 02:26

It's the local security policy for the server rather than the firewall. My previous post has a link to a KB article that has instructions on what to check. I used non-PDC instructions for Win2000/2003 and the steps are close enough to follow.

Posted by Ruben Dröge on 02-Mar-2015 02:48

Can you deploy a web service using wsaman.bat in command line? If not, what message do you get when deploying?

Posted by goz on 02-Mar-2015 03:30

I can not deploy, wsaman says that the webservice adapter is not running

Posted by goz on 02-Mar-2015 04:00

I can not deploy, wsaman says that the webservice adapter is not running

Posted by goz on 02-Mar-2015 06:31

We have tried most of the above, any1 that have any ideas of how to test where the failure is is welcome!!!

Posted by Michael Jacobs on 02-Mar-2015 06:53

If you have a configuration problem with the Tomcat's WSA web application it may not start.   Tomcat will very nicely start and appear to be running while one of its deployed web applications (such as WSA) fails start and is not accessible from clients.

If you have not already tried this:

My first stop for analyzing a connection problem, such as you see with using the wsaman utility,  is to check the Tomcat logs logs/catalina.<date>.log and logs/localhost.<date>.log.   Look for a reference to SEVERE errors when starting a [WSA] web application.  If that shows the web application starts, then check the WSA application logs for why it appears to not be running for the wsaman utility.

Something, somewhere, should indicate some form or startup/client connection error.

Posted by goz on 02-Mar-2015 08:28

I got one SEVERE error in the catalina log:

SEVERE [http-apr-] org.apache.catalina.loader.WebappClassLoaderBase.checkThreadLocalMapForLeaks The web application [olutv-wsa] created a ThreadLocal with key of type [com.progress.common.ehnlog.WsaLogContext$1] (value [com.progress.common.ehnlog.WsaLogContext$1@5794ba47]) and a value of type [java.lang.String] (value []) but failed to remove it when the web application was stopped. Threads are going to be renewed over time to try and avoid a probable memory leak.

But when I google on that error I get commets that this is an standard message...

Posted by Donicello Lampe on 02-Mar-2015 09:55

Please note that 10.2A is not supported on Windows 2012 (please see ). So there is no guarantee that this will work.

As for the ThreadLocal issue, it should only be an issue when shutting down the WSA (please see ).

Did you already increase the logging level of your WSA instance ? You can do this within the file by setting the loggingLevel=4 for your WSA instance and restarting Tomcat. Then check the wsa.log file for any clues after you try to deploy your Web Service.

Are you able to access the wsaURL from a web browser ?

Posted by goz on 05-Mar-2015 02:39

Hi everyone, thanks for all support. The issue is solved, had nothing to do with Progress or Tomcat but the server was malfunctioning. The server has 2 ip-addresses and was poorly configured. Sorry that I bothered y'all but It's always good to see that there is so many nice friends that are willing to help those in need !:-D

This thread is closed