Database has wrong version number.

Posted by rayherring on 23-Oct-2014 21:18

Fired up AppBuilder this morning and got my usual warning about a cache file being out of date, so i thought, ok, lets generate a new cache file.

Jumped onto my development server, fired up 'mpro' by doing 'mpro -pf' and issued the following command: 'SAVE CACHE /dev_pse/pse TO /usr/dev_appl/tmp/PSE.CACHE'

Biggest mistake in the world that one was, mpro gave me a 'memory violation error' and ever since then, 1 of my 3 databases refuses to start up, always returning with:

'Database has the wrong version number. (db: 25959, pro: 25773). (44)'

I have done some searching and none of the KB articles i have come across have been able to help me.

Prior to me meddling with the 'save cache' command, there was zero issues with this particular DB, the other 2 i have fire up just fine, if i remove this DB from the '' file, i can use mpro, if i keep it in there, i can't use mpro as that comes up with the exact same error too.

I'm not sure what to do to fix it now.

All Replies

Posted by rayherring on 23-Oct-2014 21:32

ok, I have fixed it for now. Had a really old backup of this particular database on the live system, copied that across, it was in OE10 version so went through the conversion steps to put it into 11.2 version and now everything is working fine again.

Age of the backup doesn't really bother me, the only thing this particular DB stores is images for part numbers we sell, and having the dev system be a little bit out of date with those images isn't an issue.

Also, the db and pro numbers are smaller now, around the 8000 mark, any reason why the bad one was in the 25k range?

Posted by mbanks on 28-Oct-2014 13:53

Sounds like the masterblock got corrupted somehow.  The version information is in the masterblock.  Maybe the corruption explains the larger size too?

This thread is closed