Open Edge 10.2A and creating a silent install

Posted by foozie000 on 12-May-2014 13:30

Hi...I am new to the Community so hi.

I have an issue with Open Edge 10.2A and silently installing the application. I have created the "setup.iss" file and it seems to be OK but when I try and install in silently nothing seems to happen.

I have tried all of the tips and tricks outlined here and in other places (ITNinja for example) without success. I am using Windows 7 32bit (if I get this to work I'll try 64bit), and I am using the netinstall (following in the footsteps of my predecessors). Since the response file seemed to be OK I had no reason to believe that this would not install silently but nothing seems to happen when I try and run it silently.

There is no ADD/REMOVE program entries and no application for Open Edge in my ..\Program Files. Not sure what else to try but I can provide any information required to address this issue.

Thanks in advance...SAS

All Replies

Posted by Dileep Dasa on 13-May-2014 00:55

Have you seen if there are any errors if you try to install interactively from setup (i.e., without silent install)?

Posted by Keerthy Yeddula on 13-May-2014 05:02


I had tried silent installation for 10.2A FCS in windows 7 32-bit cdimage and able to install successfully. Following are the steps to follow for silent installation:

1. Open Command prompt.

2. Execute the following command.

<installation path>\setup.exe -psc_s -psc_f1=<path>\<response-file-name> -psc_f2=<Path>\<response.log>

Ex: c:\cdimage\Nov 5\setup.exe -psc_s -psc_f1=c:\response.ini -psc_f2=c:\response.log

Can you please let us know is this issue you are facing is only with netinstall or the steps you followed?



Posted by egarcia on 13-May-2014 06:51


The oesetup.log file in the Windows subdirectory would have information on the install.
Perhaps, you could figure out where it is failing by comparing it with the output of an interactive install.

Something to consider is that the install of .NET and the Document Help need the user to accept the EULA. Silent install cannot install these.
If you do an interactive install, do you get a prompt for the EULA for .NET?

I hope this helps.

Posted by foozie000 on 13-May-2014 07:21

Thanks Dileep. No errors when installing from setup. That's what I found so frustrating because it works flawlessly when installing manually.

Posted by foozie000 on 13-May-2014 07:29

Thanks egarcia. There is no oesetup.log anywhere in the Windows folders. I have been trying to find some logs to compare with but there is nothing...back to the drawing board I guess.

....\dotNetFx40_Full_x86_x64.exe" /q /norestart >nul 2>&1 - This actually works and installs .NET without user interaction and it does it silently.

That issue has been covered, the problem I am having is the Progress software and without some kind of indicator about the progress of Progress I am in a quandary.

Thanks for your help.....I will much around with this and let you know.

Posted by foozie000 on 13-May-2014 07:35

Thanks kyeddula. I did find the steps you indicated in another post and it didn't work but I will try try again.

I am only using netinstall (as this is the preferred method) so I can't tell you if this works another way.

Since this is a silent install I just run a cmd file and it opens the command prompt, then loads .NET if it isn't there. Next it is supposed to run the Progress Software silently but it seems to start and end right away.

I'll keep you posted on my progress

Posted by foozie000 on 13-May-2014 07:49

I just tried it again and no luck. Seems to create the folder and stops....strange. Anymore suggestions would be appreciated...thanks

Posted by Keerthy Yeddula on 13-May-2014 10:29

Can you please provide response file you are using for silent installation.



Posted by foozie000 on 13-May-2014 10:59

I sure can. Here it is. Hopefully it kinda looks like yours.


[InstallShield Silent]


File=Response File

[File Transfer]

















ProgramFolder=OpenEdge 10.2A Shared Network Installation



Name=OpenEdge Shared Network Install Utility




Posted by Keerthy Yeddula on 14-May-2014 08:59


I have tried installing OpenEdge 10.2A with the response file provided by you and also tried with my response file using netsetup. I'm able to install OpenEdge successfully with both the files but only shortcuts for few components got created in start menu. Following is the command I used for installing OpenEdge using netsetup:

drive:\destination path\netsetup\setup.exe -psclog[C:\<path-to-file>] -s[-f1C:\<path-to-file>\response-file]



Posted by foozie000 on 14-May-2014 09:01

Thanks kyeddula. I will try the command line above and let you know my findings. I appreciate your assistance.

Posted by foozie000 on 16-May-2014 12:08

Hi kyeddula and sorry for being so long in getting back to you.

So I tried your suggestions and it still does not work. I tried to create a package with AdminStudio and it worked in Win 7 64bit but not 32bit (not sure why).

Anyway any other suggestions would be appreciated as this is becoming a full time


This thread is closed