What this means?

Posted by Admin on 18-Aug-2008 02:35

hi all,

I am trying to expose an openedge program as a webservice.

I have been fortunate to get tutorials for this.

Following it, I have managed to maje a web service.

But when I call the web service via a progress program, I get some error like

"Web Service operation TestCust generated a SOAP Fault. SOAP faultstring is : An error was detected while executing the Web Service request. (10893) (11506)"

I tried to find out what the error messages meant but couldn't get the details.

I then changed the logging level to 4 in the service I deployed.

The wsa.wsa1.log file contained a lot of things, but I assume the following thing in the message being the culprit,

"Error in SOAP request execution: Connect Failure: Application Service TestCust Unknown at NameServer at Host localhost Port 5162. (8234)"

Could anyone suggest where I am going wrong?

Thank you

All Replies

Posted by jtownsen on 18-Aug-2008 08:01

Do you have an AppServer configured to consume requests sent to the AppService Name "TestCust"? (Normally this will be automatically configured for an AppServer defined with the name "TestCust")

If you have a different name for the AppServer you wish to use (say "asbroker1"), you could either find the reference to "TestCust" and change it as appropriate or change the AppServer to also accept requests for the AppService "TestCust".

Posted by Admin on 18-Aug-2008 08:43

Hi Jamie,

Well I have followed the SOA Presentation by Sadd..,

I dont think I have configured Appserver for consuming the requests.

As you said my AppServer is running as asroker1 (default I guess),

But could you elaborate how do I find the reference to "TestCust".

I dont think this is mentioned in the Presentation though.

Thank you

Posted by jtownsen on 18-Aug-2008 09:01

I guess the paper you worked through was this one: http://www.psdn.com/library/entry!default.jspa?externalID=4293

The AppService to be called is defined on page 17 and is set in the step "Uncheck Use Default ...". Is it possible that you missed this step?

Posted by Admin on 18-Aug-2008 10:47


My intuition says that you have hit the bullseye.

But don't know why I am running into SOAP Faults again and again. Probably, needs some deep inspection of whether I did everything right.

Nevertheless, I am now getting this error.,

Error in SOAP request execution: ERROR condition: ** "TestCust.p" was not found. (293) (7211) (10926)

Posted by jtownsen on 18-Aug-2008 11:13

This sounds like the AppServer doesn't have TestCust.p in its propath

Posted by Admin on 18-Aug-2008 23:29

You hit the bullseye again , I hadn't set the ProPath earlier.

Redone everything from the scratch, followed each and every step sincerely and got the desired result.

Earlier I had just followed the Progress Session http://www.psdn.com/library/servlet/KbServlet/download/5262-102-23641/SOA-26_sadd.ppt

by John Sadd and it din't have such elaboration.

Thanks again Jamie, from bottom of my heart.

Posted by Admin on 19-Aug-2008 00:00

I dont know where to put this question,

But would like to know this.

I have setup OE (10.1A) program as a WebService and able to call it in a Sonic Process.

Is there any other way I can do this without creating the webservice in OE 10.1A?

Ya, I know that If I were to use OE 10.1C, I could have drag and drop facility of OE program in Sonic,

Thank you

Posted by Admin on 19-Aug-2008 00:48

No - that's the way to go.

But once, you have your appserver set up properly and the WSA deployed in the bus, it's not hard work anymore.

This thread is closed